
Adobe Photoshop Guide
How to create design and layer comps
A comprehensive artwork (comp for short) is a design proposal presented by the designer to the client for approval. 
Web design comps provide a rough visual draft of the overall user interface (including graphics, interface design 
elements, navigation system, and main content areas) before specific content is placed (Figure 1).

Photoshop provides an ideal prototyping environment, seamlessly converting design comps into real-world widgets, 
websites, and applications. Photoshop‘s Layer Comps panel lets you develop multiple versions of a design layout to 
show clients. 

Figure 1 Design comp 

The web design process

The typical web design process may be comprised of several stages, including any of the following:

1. Brief provides a statement of technical, design, and idea goals for the web project.

2. Research involves a range of investigative activities including a review of related web designs, analysis of 
competitor sites, user flows, personas, market analysis, use cases, and more.

3. Brainstorming is a conceptualizing stage based on the brief and research stages in which many ideas are 
generated in a short amount of time. 

4. Creative solution follows the brainstorming phase in which briefs, research, and ideas are combined to 
create a clear design direction. This stage can include technical specifications, information architecture 
diagrams, functioning wireframes, and design comps. This stage is often iterative, a repeating process in 
which problems are solved, designs are presented to clients for feedback, website functionality is developed 
and tested, and revisions are made.

5. Production fully realizes the web project. Design comps are finalized and integrated into the wireframe 
prototype, and the web project is scaled up to full production. 

As you can see, the design comp is an important piece of the web design process from the creative solution right to 
the production stage. 
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Consider the following questions as you plan and build your design comp for a web project.

Organizing content

How you organize content on a page highlights important features and elements of your web project. Important 
elements might be higher in the page, larger in size, or in stronger colors. Include rough descriptions of navigation, 
copy layout, graphic allocation, key headers, and other elements that appear on a screen. Identifying common 
structures between pages helps visitors understand they are in the same site as they navigate from page to page.

• Will your page banner be on each page? If yes, is it in the same place? Is it the same size?

• What font will you use for titles or headings on your content pages?

• What color will you use for titles or headings on your content pages?

• What font will you use for descriptions on your content pages?

• What color will you use for descriptions?

Navigation

For visitors of your website or application to understand the content, you must provide clear navigation. Visitors need 
to know where they are in a site, where they need to go, and how to get back to where they came from. Having a 
consistent layout grid helps orient visitors and keeps them from feeling lost. Using consistent buttons, links, and 
graphics on each page maintains a sense of place. As visitors move from page to page, provide familiar visual cues 
and navigational aids.

Here are some questions to answer:

• Where will you place the navigation bar on the page?

• What content will be on the navigation bar?

• Will the navigation bar be on every page?

• How will your navigation bar help visitors know which page they are on?

Creating a design comp with Adobe Photoshop

The following steps describe a typical process to follow when using Photoshop to create a design comp. The design 
comp process described here uses previously-prepared files including a background image, logo, text, and a 
photographic image.

To create the canvas and import files:

1. Start Photoshop and create a new document using the 
dimensions for your web project. 

For example, you might choose 1024x 700 pixels, which 
is the same size as the background image.

2. Choose File > Place.

The Place dialog box opens.

3. Navigate to a background image you want to use, and 
click Place.

4. To accept the placement of the image, press Enter or 
Return to apply.

The background image is placed on the canvas 
(Figure 2). Figure 2 Background image
How to create design and layer comps © 2013 Adobe Systems Incorporated

This document requires Adobe Photoshop CC, June 2013. Technical instructions may differ depending on your version.



Adobe Photoshop Guide
5. Choose File > Place.

The Place dialog box opens.

6. Navigate to a logo file and click Place.

The logo image is placed on the canvas.

7. To move the logo, drag the selection to a new position.

If you want to scale the logo, drag a handle on the 
bounding box. Press Shift as you drag a corner handle to 
scale proportionately. When positioned over a handle, the 
pointer becomes a double arrow (Figure 3).

8. To accept the placement of the image, press Enter or 
Return to apply.

9. Choose File > Place.

The Place dialog box opens.

10. Navigate to a photograph file and click Place.

The image is placed on the canvas (Figure 4).

11. To move the logo, drag the selection to a new position. 
To scale the logo, drag a handle on the bounding box.

12. To accept the placement of the image, press Enter or 
Return to apply.

13. Select File > Save, name your file and save it as a PSD in 
the Save As dialog box.

Figure 3 Scale an image

Figure 4 Placed photograph

To use drawing tools, fills, and the alignment panel:

1. From the Tools panel, select the Rectangle Tool 
(Figure 5).

2. Double-click the upper color selection box in the tool 
panel. 

The Color Picker dialog box opens (Figure 6).

3. Choose a color in the Color Picker, or enter a value in the 
HEX number field.

Alternatively, you can use the Eyedropper tool to sample 
from the active image. 

4. Drag to draw a rectangle shape at the bottom of the 
canvas.

This rectangle will become the web page footer. Next, 
you will draw the buttons for the design comp.

5. From the Tools panel, select the Rounded Rectangle tool.

6. Use the color picker to set a color for the shape.

Figure 5 Tools panel

Figure 6 Color Picker dialog box

Upper color selection box
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7. Drag on the canvas to draw a rounded rectangle suitable 
for use as a button roughly in the position you want it to 
be placed. 

A width and height dimension box helps you set the 
correct button size (Figure 7).

8. With the rounded rectangle still selected, choose Layer > 
Duplicate.

The Duplicate Layer dialog box opens (Figure 8).

9. Click OK. 

You will rename the objects in the Layers panel later.

10. Repeat the Duplicate Layer action so that there is a total 
of four buttons. Duplicates of the selected object appear 
stacked one on top of another. The most recently 
duplicated object becomes the selected object.

11. Make sure Smart Guides are visible and active. If not, 
select View > Show > Smart Guides, and then select 
Show Smart Guides and Snap To Smart Guides.

12. Select the Move tool from the tools panel and drag a 
rounded rectangle over to the right until the Smart Guides 
appear (Figure 9). 

Smart Guides help you align shapes, slices, and 
selections. They appear automatically when you draw or 
drag a shape.

13. Arrange the remaining shapes in a row between the first 
and the last rounded rectangle. 

Don’t worry about the spacing, you’ll take care of that in 
the next few steps.

14. Click in the Layers panel to select a layer containing 
another button shape (Figure 10).

If the Layers panel is not open, choose Window > Layers.

15. Use the Move tool and selecting layers to place the 
remaining shapes in a row between the first and the last 
rounded rectangle. 

Don’t worry about the spacing, you’ll take care of that in 
the next few steps.

Figure 7 Drawing a rounded rectangle

Figure 8 Duplicate Layer dialog box

Figure 9 Aligning objects using Smart Guides

Figure 10 Layers panel
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16. Shift-click the four rounded rectangle shapes in the 
Layers panel.

17. In the Move tool Control Panel, click the Align Vertical 
Centers button and the Distribute Horizontal Centers 
buttons.

The rounded rectangle shapes are vertically aligned and 
spaced evenly on the canvas.

18. In the Layers panel, double-click on each of the newly-
created shapes and give them a more descriptive name 
(Figure 12).

19. Select File > Save.

Figure 11 Drawing a rounded rectangle

Figure 12 Renaming in the Layers panel

To use text tools:

1. Select the Text tool from the Tools panel.

2. Click on the canvas just below the logo to create an auto-
sizing text block. 

An auto-sizing text block expands horizontally as you 
type and shrinks when you remove text. Auto-sizing text 
blocks are created by default when you click on the 
canvas with the Text tool and start typing.

3. Set the text characteristics in the Control panel 
(Figure 13) such as Font Family, Style, Size, and Color. 
For example, you might use a serif font for a page title.

4. Type a page title for your design comp. 

5. Use the Move tool from the tools panel and drag the text 
to the right until the Smart Guides appear and help you to 
align the title.

6. Select the Text tool from the Tools panel and drag on the 
canvas below the title and beside the photograph to create 
a fixed-width text block (Figure 14).

A fixed-width text block allows you to control the width 
of wrapped text. Fixed-width text blocks are created by 
default when you drag to draw a text block using the Text 
tool. 

7. Change Font Family to sans serif style, make the text size 
smaller and confirm the text is left aligned.

8. Add placeholder text to simulate two or three paragraphs 
of text.

9. To move the text block, select it in the Layers panel and 
drag it with the Move tool. To resize it, drag a resize 
handle.

Figure 13 Properties panel, text mode

Figure 14 Drag with Text tool to create a fixed-
width text block

Align Vertical Centers Distribute Horizontal 
Center

Font Family

Font Style

Font Color

Alignment

Font Size
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10. Select the Text tool.

You will create the labels for the buttons.

11. Click on the first rounded rectangle to create an auto-
sizing text block.

Note: Confirm in the Layers panel that your button text is 
placed above the button shapes. If not, select the text 
layer and drag it above the shape.

12. Change the font back to a serif-style font and increase the 
size slightly, style to bold and select a different text color.

13. Type a button title. 

14. Select both the text and button shape in the Layers panel 
and use the Control panel to set the alignment to centered 
horizontally and vertically, or use Smart Guides to help 
align the text to the shapes.

15. With the text block and the rounded rectangle still 
selected in the Layers panel, choose Layer > Group 
Layers.

16. Repeat steps 13 to 15 to create three more navigation 
buttons for the remaining buttons (Figure 15).

17. Create a text block at the bottom of the page, over the 
dark-gray footer rectangle and add some footer text.

18. Select File > Save.

Figure 15 Use Smart Guides to align text and 
objects

How to create layer comps with Adobe Photoshop

Designers often create multiple compositions or “comps” of a design layout to show clients. You can create comps 
out of your image’s layers by using the Layer Comps panel. Using this panel, you can create, manage, and view 
multiple versions of a layout in a single Adobe Photoshop file.

A layer comp is a snapshot of current layer visibility, position, and appearance. Layer comps capture the document as 
it currently appears.

• Layer visibility refers to whether a layer is showing or hidden.

• Layer position refers to the layer’s position in the Layer panel, above or below other layers. In your 
documents, content in upper layers appears over content in lower layers.

• Layer appearance refers to whether a layer style is applied to the layer. It also refers to the layer’s blending 
mode. For more information on layer styles and blending modes, see Photoshop Help.

When you create a layer comp, you can choose to capture one, two, or all three of these attributes.

Layer comps are best employed with images that have many layers. You will find it much easier to create layer comps 
if you are in the habit of giving layers meaningful names, such as “image_main” or “border” or “blue background.” 
When you give layers names, you can more easily identify them later.
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To create a layer comp:

1. Open a file with multiple layers in Photoshop.

2. Choose Window > Layer Comps to display the Layer 
Comps panel (Figure 16).

3. Click the Create New Layer Comp button at the bottom 
of the Layer Comps panel.

This creates a new comp that shows layers as they 
currently appear.

The New Layer Comp dialog box appears (Figure 17).

4. Type a name for the comp and add descriptive comments.

5. Select Visibility, Position, and Appearance (Layer Style).

Selecting all three options ensures that the layer comp 
will appear exactly as you want it to appear.

6. Click OK.

The current state of the layers has been saved as a layer 
comp. This means that the image’s current appearance 
has been saved as a layer comp (Figure 18).

Figure 16 Layer Comps panel

Figure 17 New Layer Comp dialog box

Figure 18 Original layout layer comp

Create New Layer Comp
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7. Using the Layers panel, make changes to the image: hide 
some layers, show others, or add more images. Your goal 
is to make the image appear significantly different than it 
appears now so you can save a different layer comp 
(Figure 19).

Note: To show or hide a layer, click the Eye icon to the 
left of it.

Next you’re going to create a new layer comp by saving 
the changes you just made in the Layers panel.

8. Repeat steps 3–6 to save your changes as another layer 
comp and provide a descriptive name for the new comp.

9. In the Layer Comps panel, click the left column next to 
the layer comp you first created (Figure 21).

When you do so, the Apply Layer Comp icon appears 
next to the layer comp, indicating it is selected.

The image changes to the first layer comp. You can now 
easily toggle between Layer Comps to compare changes.

Observe that layer visibility has now changed in the 
Layers panel.

Figure 19 Layers panel with layers selected

Figure 20 Blue background version layer comp

Figure 21 Selecting a layer comp

Apply Layer Comp icon
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Updating layer comps

After you’ve created them, you can also update layer comps.

To update a layer comp:

1. Select a layer comp in the Layer Comps panel.

2. Open the Layers panel and make changes to layer 
visibility or position.

Once you make changes to the Layers panel, the Apply 
Layer Comp icon disappears from the selected layer 
(Figure 22). The layer comp has not yet been updated, 
and the document’s current layer visibility is different 
from that saved in the layer comp.

3. Click the Update Layer Comp button to save your 
changes.

Figure 22 Layer Comps panel

Exporting layer comps

You need to export your layer comps in a form your clients can view. Photoshop generates a different PDF document 
for each layer comp. 

To export multiple layer comps as PDF documents:

1. Choose File > Scripts > Layer Comps To Files.

The Layer Comps To Files dialog box appears 
(Figure 23).

2. Click Browse to set a location on your system for the 
output file.

The Choose Folder (Windows) or Choose A Folder (Mac 
OS) dialog box appears.

3. Click OK (Windows) or Open (Mac OS) to set the 
destination.

4. In the Layer Comps To Files dialog box, enter a name for 
File Name Prefix.

5. Deselect Selected Layer Comps Only. 

This ensures that all of the layer comps in the Layer 
Comps panel will be included in the PDF.

6. From the File Type drop down menu, select PDF.

7. Click Run.

Photoshop creates individual PDF files according to your 
specifications in the location you indicated. A success 
message appears when the file creation is complete.

Figure 23 Layer Comps To Files dialog box 

Update Layer Comp button
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8. In your system, open the folder containing the PDFs.

9. Double-click a PDF file to open it (Figure 24). 

Figure 24 PDFs output to selected folder
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