
Adobe Flash Professional Guide
How to use filmmaking techniques
Web designers have an entire history of filmmaking techniques to draw from and inspire them when creating digital 
content for the web. With Adobe Flash Professional, you can simulate traditional film techniques. As you design 
Flash movies, think of creative ways to incorporate these effects and look for opportunities to create new effects that 
may in turn inspire traditional filmmaking.

You can create the following popular filmmaking techniques with Flash:

• Pan, tilt, and zoom effects: Moving the camera horizontally across a scene is known as a pan. Moving the 
camera up or down across a scene is known as a tilt. Moving the camera away from or toward a subject in a 
scene is known as a zoom.

• Camera angles: Using the rule of thirds and adjusting the viewing angle can help emphasize a certain aspect 
of your subject.

• Cross fades: One image appears to fade in while another fades out, a transitional effect for moving from one 
image to another.

• Bounce effect: A moving object rebounds before stopping. This technique grabs attention and can focus 
viewers on an area of the screen. This effect is sometimes combined with a sudden sound effect, such as a 
“boing” or tire screech.

Create a pan, tilt, or zoom effect by using classic tweens

To set a scene in a movie, the camera moves over a large scene and then zooms in to a specific point. A pan (or tilt) 
followed by a zoom is a good technique to introduce a digital narrative. Zooming in focuses the viewer’s attention on 
a particular part of the image.

To create a pan and zoom effect:

1. Open an existing Flash document or create and save a 
new Flash document (ActionScript 3.0).

2. Import an image to the Stage and convert the image to a 
movie clip symbol.

Note: To create a pan, tilt, or zoom, the image must be 
larger than the Stage. In the example, the image is about 
twice as large as the Stage (Figure 1).

3. Align the left edge of the image to the left edge of the 
Stage. 

The image should cover the Stage from top to bottom and 
extend well beyond the right edge of the Stage.

Figure 1 Image shown to the right of the Stage
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4. Click the Outline toggle button in the layer that contains 
the movie clip symbol (Figure 2).

The image (and any other content on the layer) is 
displayed as an outline.

Outline mode makes it possible to see the border of an 
object and the Stage or other objects below it (Figure 3). 

5. In the timeline, select the frame where you want the pan 
to end and select Insert > Timeline > Keyframe.

The timeline now contains start and end keyframes for 
the tween (Figure 4).

6. Turn off Outline mode by clicking the Outline toggle 
button again.

Note: Turning off Outline mode makes it easier to select 
and reposition the image.

7. Select the end keyframe. Drag the instance of the movie 
clip symbol to the left until the right edge of the image is 
aligned with the right edge of the Stage and extends off 
the Stage to the left.

Note: You can hold down the Shift key as you drag to 
maintain the vertical position of the image. 

8. Select the starting keyframe and select Insert > Classic 
Tween.

Flash adds the classic tween span between the start and 
end keyframes (Figure 5).

This classic tween moves the symbol horizontally across 
the Stage (a pan). The second keyframe that ends the 
classic tween will also serve as the starting point for the 
next tween.

9. Select Control > Test Movie > In Flash Professional to 
preview the pan.

The image pans left, as if the camera were panning right. 

10. Close the preview window.

Figure 2 Timeline panel

Figure 3 Outline mode

Figure 4 Timeline panel

Figure 5 Classic tween span

Outline toggle button

Start and end keyframes
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11. Add a third keyframe further along in the time line. 

12. Insert another classic tween between the second and third 
keyframes (Figure 6).

13. Select the third keyframe and select Modify > Transform 
> Scale.

Note: You can also select the Transform tool in the Tools 
panel.

Transform handles appear on the image (Figure 7).

14. Shift-drag one of the corner transform handles to resize 
the image.  

In this example, we made the image larger to create the 
zoom in effect.

Note: You can make the image smaller to create the 
zoom out effect, but the image needs to be larger enough 
to cover the boundaries of the Stage at all times.

15. With the image still selected, select Modify > Align > 
Align To Stage.

16. Select Modify > Align > Horizontal Center.

17. Select Modify > Align > Vertical Center.

The image will now zoom to the center of the image.

18. Select the second keyframe (the start of the second 
classic tween).

19. In the Tweening section of the Properties panel, increase 
the easing to a value between 60 and 100 (Figure 8).

The zoom will start quickly and slow down as it arrives at 
the resting point.

20. In the Timeline panel, click the New Layer button 
(Figure 9).

21. Rename the new layer actions (Figure 9).

22. Select the last frame of the actions layer and insert a new 
keyframe.

Figure 6  Classic tween span between the second 
and third keyframes

Figure 7 Transform handles

Figure 8 Properties panel, Tweening section

Figure 9 New Layer button in the Timeline panel

New Layer button
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23. Select Window > Actions to open the Actions panel 
Make sure The Actions toolbox is open and Script Assist 
is turned on (Figure 10).

Note: If the Actions toolbox is hidden, click the triangle 
or drag the vertical bar to open it. If you don’t see the 
parameters area in the Actions panel, click the Script 
Assist button.

You need to place a stop command at the end of the 
timeline to prevent the movie from looping continuously. 

24. In the Actions toolbox, choose flash.display > MovieClip 
> Methods and locate the stop method.

25. Double-click the stop method to add it to the Script pane 
in the Actions panel (Figure 11). 

Note: You can also locate the stop and other methods by 
using the Index located at the bottom of the Actions 
toolbox.

26. In the Script pane, select stop method. Then click in the 
Object text box in the parameters area of the Actions 
panel.

27. Click the Insert Target Path button (Figure 11).

The Insert Target Path dialog box appears (Figure 12).

28. Select the Relative option and select root to stop the main 
timeline from playing when the play head reaches the last 
keyframe in the movie.

29. Click OK to close the Insert Target Path dialog box.

The Script pane shows the correct code for stopping the 
movie (Figure 13). The object “this” refers to the root of 
the current timeline.

30. Close the Actions panel.

31. Select Control > Test Movie > In Flash Professional. 

This time the image pans, zooms, and then stops.

32. Close the preview window.

Figure 10 Actions panel

Figure 11 Stop method in the Script pane in the 
Actions panel

Figure 12 Insert Target Path dialog box

Figure 13 Stop method in the Script pane

Script Assist button

Parameters pane

Actions toolbox

Insert Target Path button Stop method
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Adding frame labels

You may want to add frame labels to the keyframes. Frame labels help you remember (and help other designers 
understand) what is happening in a particular frame.

To add a frame label:

1. Add a new layer called labels as the top layer of the 
timeline. 

2. Select the blank keyframe in frame 1 of the labels layer.

This aligns with the beginning of the first tween (the 
beginning of the camera pan).

3. In the Label section of the Properties panel, click in the 
Name box and type a label, such as “panning right” 
(Figure 14). Press Enter (Windows) or Return (Mac OS) 
to confirm the label.

The label appears in the timeline (Figure 15).

4. Insert a blank keyframe in the labels layer that 
corresponds to the start of the second tween. 

5. Add a second frame label above the start of the second 
tween and name it “zoom.”

Figure 14 Properties panel, Label section

Figure 15 Frame label in the timeline

Further ideas

• For a documentary: Slow the process down to reflect the pace of the narrative. For example, a slow pan and 
zoom go well with a documentary style narrative.

• For humor or action: Make the zoom-in portion of the pan quick and somewhat unsteady, as if you are 
looking for the subject of the scene. You might zoom in and out several times during a pan to show you are 
looking for something.

• For drama: Pan or tilt the scene without a zoom. This method presents a sweeping landscape, such as a 
mountain range leading to the ocean. Because it takes in the majority of the landscape, the effect adds depth 
and seriousness to the tone of the narrative.
© 2012 Adobe Systems Incorporated How to use filmmaking techniques 5

This document requires Adobe Flash Professional CS6. Technical instructions may differ depending on your version.



Guide Adobe Flash Professional

6

Camera angles

When you have several images on the screen in a digital narrative, you can use some tricks for emphasis. Use the rule 
of thirds and adjust the viewing angle to emphasize a certain aspect of the subject.

• The rule of thirds states that if you divide the screen into a 3-by-3 grid, the intersections of the lines are areas 
where the eye will focus. Line up the items of focus at these intersections on the screen.

• You can add importance to a subject by presenting the subject as seen from below. Likewise, you can 
diminish the importance of a subject as seen from above.

Even though the girl isn’t in the center of Figure 16, she 
catches your eye because she is near the intersection of 
the rule-of-thirds lines.

Looking up at the man having a moment in Figure 17 
makes him look powerful. Angling the camera down on 
him would make him look smaller and less powerful.

Figure 16 Rule of thirds

Figure 17 Camera angle
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Create cross fades by using classic tweens

A transitional effect for moving from one image to another is to fade one image out as you fade the other in.

To create a cross fade:

1. Open a new Flash document (ActionScript 3.0).

2. Import two images into the document library.

3. Select the first blank keyframe in layer 1 and drag one of 
the images to the Stage. Convert the image to a movie 
clip symbol and center it on the Stage.

4. Add keyframes at frames 20 and 30 in layer 1 
(Figure 18).

The photo will display until frame 20 and then fade out 
between frames 20 and 30. 

Note: You can place the keyframes anywhere you want 
to adjust the length of time the photo displays and the 
duration of the fade. You can also adjust these later by 
adding or removing frames.

5. Select the third (last) keyframe in layer 1. This will be the 
end of the fade.

6. Select the photo on the Stage. In the Color Effect section 
of the Properties panel, open the Style menu and choose 
Alpha (Figure 19).

The Alpha transparency value changes to the most recent 
setting you applied. The default is 0%.

7. Make sure the Alpha value is set to 0%.

The image is transparent on the Stage.

8. Select the second keyframe in layer 1 and select Insert > 
Classic Tween.

A classic tween span appears between frames 20 and 30 
(Figure 20).

9. Play the movie in the Timeline panel to see the image 
fade out.

Next you add the second image and create the fade in 
effect.

10. Add a new layer in the timeline above the first layer.

11. Insert a blank keyframe at frame 20 in the new layer. This 
will be the start of the second photo fading in 
(Figure 21).

Figure 18 Keyframes for the first photo

Figure 19 Color Effect Style menu

Figure 20 Classic tween 

Figure 21 Start of the second photo fade in 
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12. Drag the second image from the Library panel to the 
Stage. Convert the image to a movie clip symbol and 
center the image on the Stage.

13. Insert keyframes at frame 30 and 50 (or later) in the new 
layer (Figure 22).

After fading in, the second photo will play to frame 50. 
You can put this farther down the timeline to display the 
second image longer.

14. Select frame 20 in the top layer and select the photo on 
the Stage.

15. In the Properties panel, open the Color Effect Style menu 
and choose Alpha. Change the Alpha value to 0%. (It 
should switch to zero automatically).

The second photo is now transparent and you can see the 
first photo underneath it.

16.  With frame 20 still selected in the top layer, select Insert 
> Classic Tween. 

The second image starts transparent in frame 20 and 
fades in just as the first image is fading out (Figure 23).

17. Select Control > Test Movie > In Flash Professional to 
preview the movie.

18. Close the preview window.

Figure 22 Keyframes for the second image fade 

Figure 23 Fade in and fade out tweens
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Create a bounce effect by using classic tweens

Some animated text and images that move onto the Stage will seem more life-like if you add a little bounce to them 
when they reach their stopping point. This is an old animation technique acknowledging that any moving object 
carries momentum and thus rebounds a bit before it comes to a stop.

To create a bounce effect:

1. Open a new Flash document (ActionScript 3.0).

2. Begin by adding a symbol to the Stage. 

In this example we used the Oval tool to create a ball and 
converted the shape to a movie clip symbol.

3. Position the symbol near the left side of the Stage 
(Figure 24).

4. Insert a keyframe at frame 30.

5. Make sure the new keyframe is still selected and move 
the symbol to the right so that it touches the edge of the 
Stage (Figure 25).

6. Insert a keyframe at frame 40. 

7. Make sure the new keyframe is still selected and move 
the ball back to the left a little (Figure 26).

8. Insert a classic tween between frames 1 and 30.

9. Insert another classic tween between frames 30 and 40 
(Figure 27).

10. Click anywhere in the second classic tween span.

11. In the Tweening section of the Properties panel, change 
the Ease value to 80.

The ball will appear to hit the edge of the Stage wall and 
bounce back, then slow ease to a full stop. You can fine 
tune the timing of the effect by adding or removing 
frames and by adjusting the easing values.

12. Add a new layer in the Timeline panel and name it 
actions.

13. Insert a blank keyframe in the actions layer at the end of 
the movie. In this example, that’s frame 40. 

14. With the blank keyframe in the action layer selected, 
open the Action Script panel and add the stop method. 
Set the Object parameter to this to stop the main timeline 
from playing when the movie reaches the last frame 
(Figure 28).

15. Select Control > Test Movie > In Flash Professional.

The ball moves across the screen and bounces off the 
stage wall before coming to a stop.

16. Close the preview window.

Figure 24 Symbol in frame 1

Figure 25 Symbol in frame 30.

Figure 26 Symbol in frame 40.

Figure 27 Classic tweens

Figure 28 Stop method
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