
Adobe Illustrator Guide
How to use symbols, patterns, and graphic styles
A wide range of symbols, patterns and graphic styles are available within Adobe Illustrator to help you quickly and 
easily create and modify interesting design elements for your illustration projects. 

The Symbol Sprayer acts like a particle sprayer—letting you add a large number of identical objects to the artboard at 
one time. For example, use the symbol sprayer to add hundreds of grass blades, wildflowers, bees, or snowflakes. 

Pattern Creation tools allow you to create and edit vector shapes to create repeating, seamless patterns. Repeating 
patterns are often used in various industries including textiles, apparel, manufacturing, and even cartography. Pattern 
Creation tools in Illustrator allow you to easily create and edited repeating patterns at any time, so you can easily 
change artwork and tweak the design. 

You can use the Symbol Sprayer and Pattern Creation tools in Illustrator to create interesting designs or backdrops 
and then import the Illustrator file into Adobe InDesign (Figure 1).

Figure 1 Backdrop design created with Symbol Sprayer and Pattern Creation tools

A graphic style is a set of reusable appearance attributes. Graphic styles allow you to quickly change the look of an 
object; for example, you can change its fill and stroke color, alter its transparency, and apply effects in one step. All 
the changes you apply with graphic styles are completely reversible.
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About Symbols 

A symbol set is a group of symbol instances that you create with the Symbol Sprayer tool. You can create mixed sets 
of symbol instances by using the Symbol Sprayer tool with one symbol and then using it again with another symbol 
(Figure 2).

Figure 2 Artwork created with the symbolism tools

As you work with symbol sets, keep in mind that the symbolism tools affect only the symbol or symbols selected in 
the Symbols panel. For example, if you create a mixed symbol instance set that represents a meadow with grass and 
flowers, you can change the orientation of just the grass by selecting the grass symbol in the Symbols panel and then 
using the Symbol Spinner tool. To change the size of both the grass and the flowers, select both symbols in the 
Symbols panel and then use the Symbol Sizer tool.

To use the Symbol Sprayer:

1. Start Illustrator and choose File > New to display the 
New Document dialog box (Figure 3).

2. Enter the following information in the New Document 
dialog box:

• Name: Backsplash

• Number of Artboards: 1

• Units: Inches

• Orientation: Landscape

• Width: 11 in

• Height: 8.5 in

Note: These dimensions fit within the outer margins of a 
standard (8.5 x 11) two-page spread.

Figure 3 New Document dialog box

Advanced disclosure triangle
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3. If the Advanced options are not displayed, click the 
Advanced disclosure triangle to display this section of 
the New Document dialog box.

4. Enter the following settings in the Advanced section of 
the New Document dialog box:

• Color Mode: CMYK

• Raster Effects: High (300 ppi)

Color Mode refers to the way your document will print. 
CMYK is the standard mode for documents sent to a 
print vendor.

Raster Effect refers to the resolution of bitmap effects in 
the document. Set this to 300 ppi for printing.

5. Click OK.

The New Document dialog box closes and the new 
document opens.

Before you can use the Symbol Sprayer, you need to 
choose a symbol to spray.

6. Choose Window > Symbols to display the Symbols 
panel.

By default, a limited number of symbols appear in the 
Symbols panel (Figure 4).

7. Click the Symbol Libraries Menu button and choose a 
symbol library, such as Flowers (Figure 5).

8. To add a symbol to the Symbols panel, click the symbol 
in the library.

The new symbol appears in the Symbols panel 
(Figure 6).

9. Click one of the symbols in the Symbols panel to select 
it.

10. Choose the Symbol Sprayer in the Tools panel 
(Figure 7).

The pointer changes to a spray can surrounded by a wide 
circle.

Note: You can change options for the Symbol Sprayer by 
double-clicking it in the Tools panel.

11. Click on the canvas once or twice to place a few symbols.

Figure 4 Symbols panel

Figure 5 Flowers symbol library

Figure 6 New symbol added to Symbols panel

Figure 7 Tools panel

Symbol Libraries Menu button

Symbol Sprayer
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12. Drag the Symbol Sprayer across the canvas.

As you do, symbol-instance outlines appear under the 
pointer (Figure 8).

13. When you are satisfied with the number of symbols on 
the document, release the mouse button.

Symbols fill in wherever their outlines appeared 
(Figure 9).

14. Save the document.

Figure 8 Dragging with the Symbol Sprayer

Figure 9 Results of Symbol Sprayer
How to use symbols, patterns, and graphic styles © 2013 Adobe Systems Incorporated

This document requires Adobe Illustrator CC, June 2013. Technical instructions may differ depending on your version.



Adobe Illustrator Guide
To edit a symbol source in isolation mode:

1. Choose the Selection tool in the Tools panel.

2. Double-click the symbol in the Symbols panel that you 
want to edit.

The workspace enters isolation mode (Figure 10).

3. Edit the symbol as needed.

For example, you might decide to alter the colors of the 
symbol to better match a color scheme or image thematic. 
In this example, some petals of the pink flower are 
altered by color (Figure 11). This way, when you spray 
an altered symbol, all instances of that symbol appear the 
same.

4. When you finish making edits, click the Exit Symbol 
Editing Mode button in the upper-left corner (Figure 12).

Bear in mind that any changes you make in isolation 
mode affect all instances of the symbol in your document 
(Figure 13).

5. Save and close the document.

Figure 10  Isolation mode for individual symbol 
editing

Figure 11 Editing the symbol

Figure 12 Exit Symbol Editing Mode button

Figure 13 All symbols updated in the document
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Create new custom symbols

You can easily create your own, custom symbols from existing artwork (Figure 14). To base a new symbol on an 
existing piece of bitmap artwork, you can trace it and convert it to a vector format using the Image Trace command.

Figure 14 Symbol created from existing artwork.

How to create a custom symbol

1. Open or place a file you want to use as a source for the 
symbol.

2. Select the source image, and do one of the following: 

• To trace the image using a tracing preset, open the 
Tracing Presets menu in the Control panel, and select 
a preset (Figure 15).

• To trace the image using the default tracing options, 
click Image Trace in the Control panel, or choose 
Object > Image Trace > Make.

Note: If you are working with a large image, you may see 
a dialog box warning that tracing may proceed slowly, 
and asking if you would like to proceed. Click OK.

Adobe Illustrator processes the image and displays a 
Progress dialog box if the processing time is lengthy. 
When complete, the Control panel displays advanced 
Image Tracing options.

3. (Optional) Use the Control panel to adjust the results of 
the tracing by selecting other image tracing presets.

4. To manually edit the vector artwork, choose Object > 
Image Trace > Expand and convert the tracing object to 
paths. 

5. Choose Window > Symbols to display the Symbols 
panel.

Figure 15 Image Trace options menu
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6. Click New Symbol from the panel menus (Figure 16).

The Symbol Options dialog box opens (Figure 17).

7. Type a name for the symbol in the Name text box.

8. Select the symbol Type as Graphic.

9. Click OK.

The new symbol is added to the Symbols panel 
(Figure 18).

10. Select the original image source on the canvas and delete 
it.

11. Click the just-added symbols in the Symbols panel to 
select it and choose the Symbol Sprayer in the Tools 
panel.

12. Click on the canvas or drag to place symbols on the 
canvas (Figure 19).

13. (Optional) You can duplicate, edit or delete a symbol 
using options from the Symbols menu: 

• To duplicate a symbol, choose Duplicate Symbol 
from the menu. A copy of the symbol appears in the 
Symbols panel.

• To delete an existing symbol from the Symbols 
panel, choose Delete Symbol from the panel menu, 
or choose the item and click the delete symbol icon 
in the lower-right of the Symbols panel.

• To edit a symbol, choose Edit Symbol from the panel 
menu, or double-click the item in the Symbols panel. 
The workspace enters isolation mode where you can 
edit the symbol as needed. Click the Exit Symbol 
Editing Mode button in the upper-left corner. Recall 
that any changes you make in isolation mode affect 
all instances of the symbol in your document 

Figure 16 Symbols panel

Figure 17 Symbol Options dialog box

Figure 18 Symbols panel with new symbol added

Figure 19 Results of Symbol Sprayer

Symbols menu Delete symbol
© 2013 Adobe Systems Incorporated How to use symbols, patterns, and graphic styles 7

This document requires Adobe Illustrator CC, June 2013. Technical instructions may differ depending on your version.



Guide Adobe Illustrator

8

About Patterns

It’s easy to create simple, seamless patterns in Illustrator using a library object or an image of your own (Figure 20). 

Figure 20 Pattern created with the pattern tools

To use the Pattern Creation tool:

1. Start Illustrator and choose File > New to display the 
New Document dialog box.

2. Name the document and click OK.

The New Document dialog box closes and the new 
document opens.

3. Choose Window > Symbols to display the Symbols 
panel.

4. Click the Symbol Libraries Menu button and choose a 
symbol pattern library, such as Florid Vector Pack 
(Figure 21).

5. Choose one of the symbols from the Florid Vector Pack 
library, and click the symbol to add it to the library.

The new symbol appears in the Symbols panel.

6. Select the just-added object and drag it onto the artboard. 

Figure 21 Florid Vector Pack Library
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7. Choose Object > Pattern > Make.

The Pattern Options panel opens (Figure 22).

As well, a dialog box opens telling you that the new 
pattern has been added to the Swatches panel, and that 
any changes made while in Pattern Editing mode will be 
applied to the swatch upon exit.

8. Click OK to close the dialog box.

The Pattern tiles across the artboard according to the 
default settings and the pattern enters Pattern Definition 
mode (Figure 23).

Pattern Definition mode is a form of isolation mode in 
which you can modify new or existing patterns. It is 
similar to symbol editing mode. While in Pattern 
Definition mode, you can add new objects to the pattern. 
Depending on the current pattern settings, objects 
extending outside of the pattern definition area can wrap 
back in from the other side of the artboard.

Dimmed objects will appear that are replicas of the 
original, editable object. A rectangle appears around the 
original object's boundary showing the pattern definition 
area. 

9. Click the Tile Type popup menu to select a different 
repetition tiling option:

• Grid objects arranged in an even, linearly distributed 
horizontal and vertical format

• Brick by Row offsets objects linearly along a 
horizontal axis

• Brick by Column offsets objects linearly along a 
vertical axis

• Hex by Column arranges objects vertically along six 
sides of the source object

• Hex by Row arranges objects horizontally along six 
sides of the source object

Choosing a different repletion type may change the shape 
of the Pattern Definition Area boundary. You can also 
change the size of the pattern definition area, which will 
change how the objects are tiled.

10. Use the Copies menu (Figure 22) to select the number of 
grid copies that are to be included in the pattern.

11. When you finish making edits, click the Save A Copy 
button in the upper-left corner of the document window 
(Figure 23).

The New Pattern dialog box opens (Figure 24).

Figure 22 Pattern Options panel

Figure 23 Pattern tiling across the artboard

Figure 24 New Pattern dialog box

Copies 
menu

Name box

Tile Type 
menu

Exit Pattern 
Editing Mode 
button

Save A Copy 
button

Done 
button

Pattern 
definition area
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12. Give the new pattern a name and click OK. 

The new pattern is saved to the Swatches panel 
(Figure 25).

13. Click the Done button or Exit Pattern Editing Mode 
button in the upper left corner (Figure 23).

14. Select and delete the original object on the artboard.

15. Click-drag the new pattern from the Swatches panel onto 
the artboard.

Note: Double-clicking on the thumbnail in the Swatches 
panel will return you to Pattern Definition mode with an 
instance of the pattern available for editing in the 
artboard.

16. Save the document.

Figure 25 New pattern saved to Swatches panel

To create a pattern using your own image:

1. Open or place a file to use as the source image for the 
tracing and position as needed so that it has enough room 
to tile across the artboard (Figure 26).

2. Select the source image, and do one of the following: 

• To trace the image using a tracing preset, open the 
Tracing Presets menu in the Control panel, and select 
a preset (Figure 27).

• To trace the image using the default tracing options, 
click Image Trace in the Control panel, or choose 
Object > Image Trace > Make.

Note: If you are working with a large image, you may see 
a dialog box warning that tracing may proceed slowly, 
and asking if you would like to proceed. Click OK.

Adobe Illustrator processes the image and displays a 
Progress dialog box if the processing time is lengthy. 
When complete, the Control panel displays advanced 
Image Tracing options.

3. (Optional) Use the Control panel to adjust the results of 
the tracing by selecting other image tracing presets 
(Figure 27).

4. Choose Object > Pattern > Make.

The Pattern Options panel opens (Figure 22). An 
informational dialog box opens as well.

5. Click OK to close the informational dialog box.

The Pattern tiles across the artboard according to the 
default settings (or the last settings used) and the pattern 
enters Pattern Definition mode.

6. In the Pattern Options panel, adjust the Tile Type, 
number of copies, and other options. 

Figure 26 Rotating and scaling a placed image

Figure 27 Image Trace options menu
How to use symbols, patterns, and graphic styles © 2013 Adobe Systems Incorporated

This document requires Adobe Illustrator CC, June 2013. Technical instructions may differ depending on your version.



Adobe Illustrator Guide
7. When you finish making edits, click the Save A Copy 
button in the upper-left corner of the document window.

The New Pattern dialog box opens.

8. Give the new pattern a name and click OK. 

The new pattern is saved to the Swatches panel.

9. Click the Done button or Exit Pattern Editing Mode 
button in the upper-left corner of the document window.

10. Select and delete the original object on the artboard.

11. Click-drag the new pattern from the Swatches panel onto 
the artboard (Figure 28).

12. Save the document.
Figure 28  Placing the new pattern onto the 
artboard

Importing symbols and patterns into InDesign

Once you’ve completed your symbol and pattern designs in Illustrator, you can import the files into Adobe InDesign.

To add Illustrator images to an InDesign page spread:

1. Start InDesign and create a new document with the 
following specifications.

• Number of Pages: 1

• Page Size: Letter

• Orientation: Landscape

2. Click OK.

3. Choose File > Place.

The Place dialog box appears.

4. Browse to the location of the Adobe Illustrator file you 
saved in the previous steps, and select it.

5. Make sure the Show Import Options option is selected in 
the Place dialog box. Click Open.

The Place PDF dialog box appears (Figure 29).

6. Make sure Preview is selected. Select an option in the 
Crop To menu to specify how the imported image is to be 
cropped.

With the Preview option, you can preview the Adobe 
Illustrator file in the left section of the Place PDF dialog 
box.

7. Click OK.

The image replaces the pointer as a thumbnail image.

8. Click to place the image into the spread (Figure 30).

Figure 29  Place PDF dialog box

Figure 30 Image placed in spread
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9. (Optional) Move and scale image to fit the spread.

10. Choose Window > Layers to display the Layers panel.

11. Add a new layer, and rename the original layer 
Background.

12. Add content to the spread (text and graphic frames) in the 
new layer.

13. Save the InDesign file.

Note: To reuse the design on multiple pages, you could 
add the background to a master page. For more 
information on master pages, see InDesign Help.

Working with graphic styles

A graphic style is a set of reusable appearance attributes that allow you to quickly change the look of an object 
(Figure 31). You can apply graphic styles to objects, groups, and layers. When you apply a graphic style to a group or 
layer, every object in the group or layer takes on the attributes of the graphic style. For example, assume you have a 
graphic style that consists of 50% opacity. If you apply the graphic style to a layer, all objects in or added to that layer 
will appear 50% opaque. However, if you move an object out of the layer, the object’s appearance reverts to its 
previous opacity. 

Figure 31 Applying a Graphic style for type with text for the preview

Graphic Styles panel overview

You use the Graphic Styles panel (Window > Graphic Styles) to create, name, and apply sets of appearance attributes. 
The panel lists a default set of graphic styles when you create a document. Graphic styles that are saved with the 
active document appear in the panel when that document is open and active.

If a style doesn’t have a fill and stroke (for example, an effect-only style) the thumbnail appears in the shape of the 
object with a black outline and white fill. In addition, a little red slash appears, indicating the absence of a fill or 
stroke.If you’ve created a style for type, choose Use Text For Preview from the Graphics Styles panel menu to see a 
thumbnail of the style applied to a letter rather than a square. To see any style more clearly, or to preview the style on 
a selected object, right-click (Windows) or Ctrl-click (Mac OS) the style’s thumbnail in the Graphic Styles panel and 
view the large pop-up thumbnail that appears. 
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How to create a graphic style:

1. To create a graphic text style from scratch, add a block of 
text then it and apply any combination of appearance 
attributes, including fills and strokes, effects, and 
transparency settings.

2. Choose Window > Graphic Styles to display the Graphic 
Styles panel (Figure 32).

3. Select New Graphic Style from the panel menu.

The Graphic Style Options dialog box opens (Figure 33).

4. Type a name in the Style Name box.

5. Click OK.

The new graphic style is added to the Graphic Styles 
panel.

6. From the Graphic Styles panel menu, choose Use Text 
For Preview to see a thumbnail of the style applied 
(Figure 34).

The Graphics Styles panel view is updated (Figure 35).

7. To apply a text graphic style to second block of text, 
select the text and apply a rough style. 

For example you might initially set the font size, stroke 
and fill for a text, these elements will not change when 
you apply the graphic style.

Figure 32 Graphic Styles panel

Figure 33 Graphic Style Options dialog box

Figure 34 Graphic Style Options menu

Figure 35 Graphic Style panel

Graphics Styles menu 
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8. Select the just-created style from the Graphic Styles 
panel to apply it to a block of text (Figure 36).

9. (Optional) You can duplicate, edit or delete a style using 
options from the Graphic Style menu: 

• To duplicate a symbol, choose Graphic Style from 
the panel menu. A copy of the symbol appears in the 
Symbols panel.

• To delete an existing symbol from the Symbols 
panel, choose Delete Symbol from the panel menu, 
or choose the item and click the delete symbol icon 
in the lower-right of the Symbols panel.

• To merge a style with an object’s existing style 
attributes, or apply multiple styles, select the object 
and then Alt-click (Windows) or Option-click (Mac 
OS) the style in the Graphic Styles panel.

10. Add the graphic styles you want to the Graphic Styles 
panel, and delete any graphic styles you don’t want.

Note: To select all graphic styles that aren’t used in a 
document, choose Select All Unused from the Graphic 
Styles panel menu and click the trash can icon to delete.

You may now want to save your newly-created styles as a 
graphic style library for use in another project. 

Graphic style libraries are collections of preset graphic 
styles. When you open a graphic style library, it appears 
in a new panel (not the Graphic Styles panel). You select, 
sort, and view items in a graphic style library the same as 
you do in the Graphic Styles panel. 

11. To save a library, choose Save Graphic Style Library 
from the Graphic Styles panel menu. 

12. The Save Graphic Styles as Library dialog box opens. 

13. Type a name in the File Name box and click Save.

14. To open your custom Graphics Styles Library, choose 
Window > Graphic Style Libraries > User Defined > 
<your library)> (Figure 37).

The custom Graphic Styles Library panel opens 
(Figure 38). 

You can also import graphic styles from other documents. 

15. Choose Window > Graphic Style Libraries > Other 
Library.

16. Select the file from which you want to import graphic 
styles, and click Open. 

The graphic styles appear in a graphic style library panel. 

Figure 36 Text before style applied (top) and after 
Graphic Style applied (bottom)

Figure 37 Window > Graphic Styles Libraries 
options

Figure 38 Botany Styles saved Graphic Styles 
Library
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