Adobe lllustrator Guide

How to export and save files

Ilustrator is popular with designers because they can create graphics that can be used in a wide variety of
applications. You can easily save your work for print, video, or the web. When you save for the web, additional
options are available that will generate usable CSS code for use in other projects and applications (Figure 1).
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Saving your work to the Creative Cloud makes your files available to you anywhere and on any device or computer.
You can preview many creative file types directly in a web browser on your computer, tablet, or smartphone. These
file types include PSD, Al, INDD, JPG, PDF, GIF, PNG, Photoshop Touch, Ideas, and others.

Saving for print

To make optimum decisions about printing, you should understand basic printing principles, including how the
resolution of your printer or the calibration and resolution of your monitor can affect the way your artwork appears
when printed. lllustrator’s Print dialog box (Figure 2) is designed to help you through the printing workflow. Each set
of options in the dialog box is organized to guide you through the printing process.

Figure 2 Print dialog box
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Printing a composite of artwork from the dialog box helps you to fine-tune your project for print. A composite is a
single-page version of artwork that corresponds to what you see in the illustration window—in other words, a
straightforward print job. Composites are also useful for proofing the overall page design, verifying image resolution,
and identifying problems that may occur on an imagesetter (such as PostScript errors).

How to print a composite of an artwork to PDF:

1. Choose File > Print.

Print Preset: | Custom
The Print dialog box opens (Figure 2). rint Prese n

2. Toprintto afile, select Adobe PostScript® File or Adobe
PDF from the Printer menu (Figure 3). PPD:

Printer: Adobe PDF
Adobe PostScript® File

3. Choose one of the following artboard options: itk £2Convorts

- - neral Send To OneNote
« To print everything on one page, select Ignore Send To Neat

Artboards in the General area of the dialog box Copies: : Sl :
. Microsoft XP5 Document Writer
(Figure 4). o
Arthoards: Eix
e To print each artboard separately, deselect Ignore T
Arthoards and specify if you want to print all —

artboards (All) or a specific range, such as 1-3. Figure 3 Print dialog box Print Preset menu

4. Select Output on the left side of the Print dialog box, and
make sure Mode is set to Composite. General

5. Set additional printing options. copies: FIIIN Reverse Order
6. Click Print. Arthoards:

The Save PDF dialog box opens.
7. Name the file, browse to a location, and click Save. + Ignore Artboards

The composite is saved as a PDF (Figure 5). Figure 4 General area of the Print dialog box

Note: If your document uses layers, you can specify which
ones to print. Choose File > Print, and select an option from
the Print Layers menu: Visible And Printable Layers, Visible
Layers, or All Layers.

Figure 5 Printed PDF

Saving for video

Illustrator can create images of various aspect ratios so they appear properly on devices such as video monitors. You
can select a specific video option (using the New dialog box) to compensate for scaling when the final image is
incorporated into video.
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Safe zones

The Video and Film preset provides several preset video- and film-specific crop area sizes (note that the Artboard
option changes to Crop Size for this profile). The document is created with nonprinting guides that delineate the
action-safe and title-safe areas of the image (Figure 6).
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Figure 6 Video preset file size guides include action safe area (outer rectangle) and title safe area (inner rectangle)

Safe zones are useful when you edit for broadcast and videotape. Most consumer TV sets use a process called
overscan, which cuts off a portion of the outer edges of the picture, allowing the center of the picture to be enlarged.
The amount of overscan is not consistent across TVs. To ensure everything fits within the area most TVs display,
keep text within the title-safe margins, and all other important elements within the action-safe margins.

Illustrator creates only square pixel files, so to ensure that the sizes are interpreted correctly in video applications,
Ilustrator adjusts the Width and Height values. For example, if you choose NTSC DV Standard, Illustrator uses a
pixel size of 654 x 480, which translates to 740 x 480 pixels in video-based applications.

How to save for video:

1. Choose File > New. NewOoamen:
The New Document dialog box opens (Figure 7). =

2. From Profile, select the Video and Film profile. o e A

Number of Artboards: <

3. Type a name for your document.

Size: | NTSC DV Widescreen

width:

Height: Orientation: |

Top Bottom Left Right
slecd: [N ~ [N ~E3 ~[E3 °
» Advanced

Color Mode:RGB, PPI:72, Align to Pixel Grid:No

Figure 7 Start top of column
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4. Specify the number of artboards for your document, the
order you’d like them laid out on screen, and other

SC DV Widescreen

options. Width:

5. Select a video preset size from the Size menu (Figure 8). i i

6. Click OK to close the New Document dialog box. T e [:ll SR
The Video and Film template opens as a new document : HTL [;1 Widescraon

(Figure 6). OAL DI/DV

PAL D1/DV Widescreen
HDV/HDTV 720

HDW 1080

DVCPRO HD 720
DVCPRO HD 1080

HDTV 1080

Figure 8 Start anywhere

Saving for the web

Illustrator provides a variety of tools for creating layout for web pages or creating and optimizing web graphics. For
example, use web-safe colors, balance image quality with file size, and choose the best file format for your graphic.
Web graphics can take advantage of slices and image maps, and you can use a variety of optimization options to
ensure your files display well on the web. You use the Save For Web dialog box to select optimization options and
preview optimized artwork (Figure 9).

Save for Web

Cancel Done

Figure 9 Save For Web dialog box
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How to optimize an image for the web:

1.

Choose File > Save For Web.
The Save For Web dialog box opens (Figure 9).

Click a tab at the top of the dialog box to select a display
option: Optimized, 2-Up, or 4-Up. If you select 4-Up,
click the preview you want to optimize.

(Optional) If your image contains multiple slices, select
one or more slices you want to optimize.

Select a preset optimization setting from the Preset menu
(Figure 10), or set individual optimization options. The
available options change depending on the file format
you select.

Fine-tune the optimization settings until you are satisfied
with the balance of image quality and file size

(Figure 11). If your image contains multiple slices, be
sure to optimize all the slices.

If optimizing an image with an embedded color profile
other than sRGB, you should convert the image’s colors
to SRGB before you save the image for use on the web.
This ensures that the colors you see in the optimized
image will look the same in different web browsers. The
Convert To sRGB option is selected by default.

Click Save.

In the Save Optimized As dialog box, do the following,
and then click Save:

» Enter a filename, and select a location for the
resulting file or files.

e Select a Format option to specify what kind of files
you want to save: an HTML file and image files,
only image files, or only an HTML file.

*  (Optional) Set output settings for HTML and image
files.

» Ifyour image contains multiple slices, select an
option for saving slices from the Slices menu: All
Slices or Selected Slices.

The image is optimized for the web (Figure 12)
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Figure 10 Image Preset options

Figure 12 Optimized, exported image
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Generating CSS code

You can easily create the design for an HTML page in Illustrator. This serves as a good visual guide for a web
developer, who can then code the layout, styles, and objects into a page in an HTML editor. However, replicating the
exact appearance and position of components and objects is a time-consuming and tedious process.

With Illustrator, you create the layout for an HTML page and then also generate and export the underlying CSS code
that determines the appearance of the components and objects on the page. CSS allows you to control the appearance
of text and objects (similar to character and graphic styles). You can choose to export the CSS code for individual
objects or for the entire layout designed in Illustrator.

In the CSS Properties panel (Figure 13), you can do the following:
»  View the CSS code for selected objects.
»  Copy the CSS code for selected objects.
»  Export one or more, or all selected Illustrator elements to a CSS file.
»  Export rasterizable images used.

»  Generate browser-specific CSS code.

55 Properties

A links
A subheadcaps
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A capswithbar
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Export options  Export Copy Generate
selected CSS selected CSS  CSS

Figure 13 CSS Properties panel

How to view and extract CSS code:

1. To generate CSS code, ensure that objects in your
Ilustrator document are named in the Layers panel
(Figure 14).

2. Select Window > CSS Properties.
The CSS Properties panel opens (Figure 13).

Figure 14 Layers panel
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3. Inan open Illustrator document, do one of the following:

»  Select one object (Figure 15). The CSS code for the
object is displayed in the CSS Properties panel
(Figure 16).

» Hold Shift, select multiple objects, and then click the
Generate CSS button in the CSS Properties panel.

*  Press Ctrl/Cmd + A to select all the objects, and then
click the Generate CSS button in the CSS Properties
panel.

The generated CSS code is displayed.

4. To obtain the CSS code that has been generated, do one
of the following:

To copy selected code, select specific code, and then:
»  To copy to the clipboard, click Copy Selected Style.

» To export to a file, click the flyout menu, and then
click Export Selected CSS.

To copy all the code, make no selection in the CSS code,
and then:

»  To copy to the clipboard, click Copy Selected Style.

» To export to a file, click the flyout menu, and then
click Export All.

5. While saving CSS code to a file, set the CSS options in
the CSS Export Options dialog box (Figure 17).

The exported CSS is ready to be placed within another
application, such as Dreamweaver (Figure 20).
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Figure 16 CSS code for selected image
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Figure 17 CSS Export Options dialog box
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Figure 18 Exported CSS in Dreamweaver
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Saving to Creative Cloud

Your Adobe Creative Cloud account comes with online storage so your files are available to you anywhere and on
any device or computer (Figure 19). You can preview many creative file types directly in a web browser on your
computer, tablet, or smartphone. These file types include PSD, Al, INDD, JPG, PDF, GIF, PNG, Photoshop Touch,

ldeas, and others.
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Figure 19 Creative Cloud Files page

How to save to Creative Cloud:
1. Log into your Creative Cloud account.

2. Drag and drop assets from your desktop to the Files page
on Creative Cloud (Figure 20).

You can also upload and manage your files on Creative
Cloud by using the Actions button on the Creative Cloud

Files page (Figure 19).
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Figure 20 Drag and drop files
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3. To delete files, select the Archive option by clicking the
menu triangle in the lower-right corner of the file

(Figure 21).
4. Click the Archive button to confirm.

The item is moved to the Archive page (Figure 22).

5. To permanently delete files, select the files to delete
permanently and click the Permanently Delete option in

the Action menu (Figure 23).

6. Inthe confirmation dialog box, click Permanently Delete

(Figure 24).
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