
Adobe Illustrator Guide
How to draw in Illustrator
You can easily draw and modify vector paths and shapes by using a set of drawing tools and techniques in Adobe 
Illustrator. Vector graphics (sometimes called vector shapes or vector objects) are made up of lines and curves defined 
by mathematical objects called vectors, which describe an image according to its geometric characteristics. You can 
freely move or modify vector graphics without losing detail or clarity because they are resolution-independent—they 
maintain crisp edges when resized, printed to a PostScript printer, saved in a PDF file, or imported into a vector-based 
graphics application. As a result, vector graphics are the best choice for artwork, such as logos, that will be used at 
various sizes and in various output media (Figure 1). 

Figure 1 An example of vector-based artwork produced in Adobe Illustrator

As you draw in Illustrator, the mathematical formulas create paths. Paths are lines that connect one point to another. 
Almost everything you draw in Illustrator is made up of paths. Because these paths are made up of connection points, 
you can adjust the connection points to change the shape of the path.

Adobe Illustrator is a powerful and professional-level vector graphics editor where the tasks and options for drawing 
are numerous. This guide serves as an introduction to Illustrator drawing tools and covers the following:

• Drawing with the Pencil tool

• How to work with brushes

• Drawing with the Pen tool

• Drawing with the Blob Brush tool

• Drawing shapes with the Shape tool and the Shape Builder tool

After you complete this guide, be sure to continue exploring the full breadth of drawing and shape tools available in 
Illustrator by checking out the Help section of the Adobe website.
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Drawing with the Pencil tool

You can use the Pencil to draw open and closed paths as if you were drawing with a pencil on paper. It is most useful 
for fast sketching or creating a hand-drawn look. Once you draw a path, you can immediately change it if needed.

Anchor points are set down as you draw with the Pencil tool; you do not determine where they are positioned. 
However, you can adjust them once the path is complete. The number of anchor points set down is determined by the 
length and complexity of the path and by tolerance settings in the Pencil Tool Preferences dialog box. These settings 
control how sensitive the Pencil tool is to the movement of your mouse or graphics-tablet stylus.

When you use a drawing tool (in this case, the Pencil tool), the Control panel displays options for the currently 
selected tool (Figure 2).

• Fill color: The interior color of a shape. Select from a series of swatches.

• Stroke color: The outline of a shape. Select from a series of swatches.

• Stroke weight: Weight for the stroke, in points.

• Variable Width Profile: Choose a preset that modifies the width of a stroke and save it as a custom profile.

• Brush Definition: A wide selection of preset brushes. You can also create your own.

• Opacity: Transparency for painted lines, from 0% (invisible) to 100% (opaque).

• Graphic Style panel: A graphic style is a set of reusable appearance attributes, such as fill and stroke color, 
transparency, and special effects.

• Recolor Artwork: Quickly change the color of an object. 

• Align To Selection: Align or distribute selected objects along the axis you specify.

• Transform panel: Displays information about the location, size, and orientation of one or more selected 
objects. Select the Scale Strokes And Effects option in the panel menu to ensure transformations maintain 
consistent scale.

• Isolate Selected Object button: Isolate the selected object from other objects in a workspace.

• Select Similar Objects button: Select objects with similar characteristics in a workspace.

Figure 2 Control panel

In this section, you’ll learn about creating freeform paths with the Pencil tool, using the three drawing modes to layer 
paths and objects, and modifying a stroke by using the Path Control panel.
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To draw a freeform path with the Pencil tool:

1. Select the Pencil tool in the Tools panel (Figure 3).

2. Set the stroke color and thickness in the Control panel 
(Figure 2).

3. Position the tool where you want the path to begin, and 
drag to draw a path. 

The Pencil tool displays a small asterisk to indicate you 
are drawing a freeform path (Figure 4).

As you drag, you create a line with connection points. 
You can drag these points later to change the shape of the 
line.

4. Release the mouse button to create the line (Figure 5).

Figure 3 Tools panel

Figure 4 Drawing a line with Pencil tool 

Figure 5 Line drawn with Pencil tool

Using drawing modes

Illustrator provides the following drawing modes: Draw Normal, Draw Behind, Draw Inside. You can select drawing 
modes from the Tools panel, below the Color Selector tool (Figure 6).

Figure 6 Draw Normal (A), Draw Behind (B), and Draw Inside (C)

The Draw Normal mode is the default drawing mode and allows you to draw on top of other paths and objects. 

The Draw Behind mode allows you to draw behind all artwork on a selected layer if no artwork is selected. If an 
artwork is selected, the new object is drawn directly beneath the selected object.

The Draw Inside mode allows you to draw inside the selected object. The Draw Inside mode eliminates the need to 
perform multiple tasks such as drawing and altering stacking order or drawing, selecting, and creating a clipping 
mask. The Draw Inside mode is enabled only when there is a single selected object (path, compound path, or text). 

Pencil tool
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How to use drawing modes:

1. To switch drawing modes, click the Drawing Modes 
panel in the Tools panel (Figure 6) and select the Draw 
Behind drawing mode.

2. Select the Pencil tool in the Tools panel.

3. Set a different stroke color and thickness in the Control 
panel from the previous steps.

4. Position the tool where you want the path to begin, and 
drag to draw a path that overlaps the strokes.

Observe how the line is drawn on a layer beneath the 
original layer (Figure 7).

5. Select a shape tool from the Tools panel, for example, the 
Ellipse tool.

6. Draw a shape on the canvas and set the stroke and fill 
properties in the Control panel.

7. Choose the Selection tool in the Tools panel and select 
the shape.

The Draw Inside mode is enabled only when there is a 
single selected object (path, compound path, or text). 

8. Click the Drawing Modes panel in the Tools panel and 
select the Draw Inside drawing mode.

A dotted bounding box appears around the selected shape 
(Figure 8)

9. Select the Pencil tool in the Tools panel.

10. Set a different stroke color and thickness in the Control 
panel.

11. Drag to draw a path that overlaps the object and extends 
beyond its boundaries (Figure 9).

Observe how the finished line appears only inside the 
original shape (Figure 10).

Figure 7 Draw Behind mode

Figure 8 Draw Inside bounding box

Figure 9 Start anywhere

Figure 10 Start anywhere
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Modifying a stroke

Strokes (lines and outlines) and brushes are essential elements of most all artwork created with Illustrator. You can 
modify a stroke to create beautiful and visually expressive lines. Easily adjust the width of strokes by applying a 
variable-width preset. You can also add a gradient to a stroke along its length or width, with complete control over 
gradient placement and opacity.

To create a stroke with a variable width:

1. Choose the Selection tool in the Tools panel.

2. Select the stroke you want to modify (Figure 11).

3. Choose a stroke profile from the Variable Width Profile 
menu in the Control panel (Figure 12).

The new stroke profile is applied (Figure 13). Increasing 
the weight of the stroke generally makes the variation in 
width more pronounced.

Note: You can also modify the width of a stroke and save 
it as a custom profile by using the Width tool. See 
Illustrator Help for more information.

4. With the stroke still selected, click the Stroke color 
button in the Path Control panel.

The Color Picker opens (Figure 14). 

Note: Holding down the Shift key while clicking brings 
up an alternate color UI where you can specify exact 
CMYK values.

Figure 11 Selecting a stroke

Figure 12 Variable Width Profile options

Figure 13 Variable Width Profile applied

Figure 14 Color Picker
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5. Select a gradient option to apply.

For example, in Figure 15, a multi-colored Green, 
Yellow, Orange stroke gradient is applied to the stroke.

Note: You can easily modify the stroke gradient type, 
gradient angle, colors, and opacities by using the 
Gradient panel. See “Using the Gradient tool” later in this 
guide.

Figure 15 Stroke gradient applied

Drawing with the Pen tool

As you draw with the Pen tool, you create a line called a path. A path is made up of one or more straight or curved 
segments (Figure 16). The beginning and end of each segment are marked by anchor points, which work like pins 
holding a wire in place. A path can be closed (for example, a circle), or open, with distinct endpoints (for example, a 
wavy line).

Figure 16 Pen tool with straight lines (left) and curved lines (right)

Adding anchor points can give you more control over a path, or it can extend an open path. However, it’s a good idea 
not to add more points than necessary. A path with fewer points is easier to edit, display, and print. You can reduce the 
complexity of a path by deleting unnecessary points. Adding and deleting anchor points works similarly in Adobe 
applications. The Tools panel contains three tools for adding or deleting points: the Pen tool, the Add Anchor Point 
tool, and the Delete Anchor Point tool. In addition, the Control panel has a Remove Selected Anchor Points button.

The simplest path you can draw with the Pen tool is a straight line, made by clicking the Pen tool to create two anchor 
points. By continuing to click, you create a path made of straight-line segments connected by corner points. 

You create a curve by adding an anchor point where a curve changes direction, and dragging the direction lines that 
shape the curve. The length and slope of the direction lines determine the shape of the curve. Curves are easier to edit 
and your system can display and print them faster if you draw them using as few anchor points as possible. Using too 
many points can also introduce unwanted bumps in a curve. Instead, draw widely spaced anchor points, and practice 
shaping curves by adjusting the length and angles of the direction lines. 

When you select an anchor point that connects curved segments (or select the segment itself), the anchor points of the 
connecting segments display direction handles—direction lines that end in direction points. The angle and length of 
the direction lines determine the shape and size of the curved segments. Moving the direction points reshapes the 
curves. Direction lines don’t appear in the final output.

In this section, you’ll use the Pen tool to draw both straight and curved lines.
How to draw in Illustrator © 2013 Adobe Systems Incorporated

This document requires Adobe Illustrator CC, June 2013. Technical instructions may differ depending on your version.



Adobe Illustrator Guide
How to draw straight-line segments with the Pen tool:

1. Select the Pen tool from the Tools panel (Figure 17). 

2. Position the Pen tool where you want the straight 
segment to begin, and click to define the first anchor 
point (do not drag). 

Note: The first segment you draw will not be visible until 
you click a second anchor point. Also, if direction lines 
appear, you’ve accidentally dragged the Pen tool; choose 
Edit > Undo, and click again.

3. Click again where you want the segment to end 
(Figure 18).

4. Continue clicking to set anchor points for additional 
straight segments.

The last anchor point you add always appears as a solid 
square, indicating that it is selected. Previously defined 
anchor points become hollow, and deselected, as you add 
more anchor points.

5. Complete the path by doing one of the following:

• To close the path, position the Pen tool over the first 
(hollow) anchor point. A small circle appears next to 
the Pen tool pointer when it is positioned correctly 
(Figure 19). Click or drag to close the path.

Note: To close a path, you can also select the object 
and choose Object > Paths > Close Path.

• To leave the path open, Ctrl-click (Windows) or 
Command-click (Mac OS) anywhere away from all 
objects.

To leave the path open, you can also select a 
different tool, or choose Select > Deselect in 
Illustrator or Edit >Deselect All. You can also simply 
press Enter or Return to leave the path open.

6. You can reposition anchor points by choosing the Direct 
Selection tool from the toolbar and dragging to reposition 
the anchor point (Figure 20).

7. To add or delete anchor points, select the path you want 
to modify and:

• To add an anchor point, select the Pen tool or the 
Add Anchor Point tool, position the pointer over the 
path segment, and click.

• To delete an anchor point, select the Pen tool or the 
Delete Anchor Point tool, position the pointer over 
the anchor point, and click (Figure 21).

Figure 17 Tools panel

Figure 18 Click to create straight lines

Figure 19 Pen tool with circle icon

Figure 20 Drag anchor point to reposition

Figure 21 Click an anchor point to delete

Pen tool
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How to draw curves with the Pen tool:

1. Select the Pen tool from the Tools panel.

2. Position the Pen tool where you want the curve to begin, 
and hold down the mouse button.

The first anchor point appears, and the Pen tool pointer 
changes to an arrowhead.

3. Drag to set the slope of the curve segment you’re creating 
(Figure 22), and then release the mouse button. 

In general, extend the direction line about one-third of the 
distance to the next anchor point you plan to draw. (You 
can adjust one or both sides of the direction line later.)

4. Position the Pen tool where you want the curve segment 
to end, and do one of the following:

• To create a C-shaped curve, drag in a direction 
opposite to the previous direction line. Then release 
the mouse button.

• To create an S-shaped curve, drag in the same 
direction as the previous direction line (Figure 23). 
Then release the mouse button.

5. Continue dragging the Pen tool from different locations 
to create a series of smooth curves. Note that you are 
placing anchor points at the beginning and end of each 
curve, not at the tip of the curve.

6. Complete the path by doing one of the following:

• To close the path, position the Pen tool over the first 
(hollow) anchor point. A small circle appears next to 
the Pen tool pointer when it is positioned correctly 
(Figure 24). Click or drag to close the path.

Note: To close a path in InDesign, you can also 
select the object and choose Object > Paths > Close 
Path.

• To leave the path open, Ctrl-click (Windows) or 
Command-click (Mac OS) anywhere away from all 
objects.

To leave the path open, you can also select a 
different tool, or choose Select > Deselect in 
Illustrator or Edit >Deselect All in InDesign.

7. You can reposition anchor points by choosing the Direct 
Selection tool from the toolbar and dragging to reposition 
the anchor point.

Figure 22 Drawing the first point in a curve: A. 
Positioning Pen tool B. Starting to drag (mouse 
button pressed) C. Dragging to extend direction 
lines

Figure 23 Drawing an S curve

Figure 24 Start top of column
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8. To add or delete anchor points, select the path you want 
to modify and

• To add an anchor point, select the Pen tool or the 
Add Anchor Point tool, position the pointer over the 
path segment, and click.

• To delete an anchor point, select the Pen tool or the 
Delete Anchor Point tool, position the pointer over 
the anchor point, and click.

How to work with brushes

You can use brushes to stylize the appearance of paths. You can apply brush strokes to existing paths, or you can use 
the Paintbrush tool to draw a path and apply a brush stroke simultaneously.

You can achieve a variety of effects with several types of brushes available in Illustrator (Figure 25):

• Calligraphic brushes: Create strokes that resemble those drawn with the angled point of a calligraphic pen 
and along the center of the path. When you use the Blob Brush tool, you can paint with a calligraphic brush 
and automatically expand the brush stroke into a fill shape. This shape can merge with other filled objects of 
the same color that intersect or are adjacent in stacking order.

• Scatter brushes: Disperse copies of an object (such as a ladybug or a leaf) along the path.

• Art brushes: Stretch a brush shape (such as Rough Charcoal) evenly along the length of a path.

• Bristle brush: Create brush strokes with the appearance of a natural brush with bristles.

• Pattern brushes: Paint a pattern—made of individual tiles—that repeats along the path. Pattern brushes can 
include up to five tiles, for the sides, inner corner, outer corner, beginning, and end of the pattern.

Figure 25 Types of brushes: A. Calligraphic Brush; B. Scatter Brush; C. Art Brush; D. Pattern Brush; E. Bristle 
Brush

Scatter brushes and Pattern brushes can often achieve the same effect. However, one way in which they differ is that 
Pattern brushes follow the path exactly, while Scatter brushes do not (Figure 26).

Figure 26 Pattern brush on a path (left) and Scatter brushes on a path (right)
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The Brushes panel displays brushes for the current file (Figure 27). Whenever you select a brush in a brush library, it 
is automatically added to the Brushes panel. Brushes you create and store in the Brushes panel are associated only 
with the current file, which means each Illustrator file can have a different set of brushes in its Brushes panel. For 
example, the Bristle Brush Library features brush tips that give the appearance of brush strokes along a path.

Figure 27 Bristle Brush Library (left) and Brushes panel (right)

In this section you’ll learn how to use brushes and brush libraries, and how to paint with a brush made from a photo.

How to show/hide, change views or order of brushes, duplicate or delete brushes:

To show or hide a type of brush, choose any of the following 
from the panel menu (Figure 28): Show Calligraphic 
Brushes, Show Scatter Brushes, Show Art Brushes, Show 
Bristle Brushes, Show Pattern Brushes.

To change the view of brushes, choose Thumbnail View or 
List View from the panel menu.

To change the order of brushes in the Brushes panel, drag a 
brush to a new location (Figure 29). You can move brushes 
only within their type. For example, you cannot move a 
Calligraphic brush to the Scatter brush area.

To duplicate a brush in the Brushes panel, drag the brush onto 
the New Brush button or choose Duplicate Brush from the 
Brushes panel menu.

To delete a brush from the Brushes panel, select the brush and 
click the Delete Brush button. You can select brushes that 
aren’t used in a document by choosing Select All Unused 
from the Brushes panel menu.

Figure 28 Detail of Brushes panel menu 

Figure 29 Drag brush to a new location

Panel menu

New Brush

Delete Brush

Click to add to 
Brushes panel
How to draw in Illustrator © 2013 Adobe Systems Incorporated

This document requires Adobe Illustrator CC, June 2013. Technical instructions may differ depending on your version.



Adobe Illustrator Guide
To draw with the Paintbrush tool:

1. Select the Paintbrush tool in the Tools panel (Figure 30).

2. Choose a stroke color in the Control panel.

3. Choose Window > Brushes to display the Brushes panel.

4. From the Brushes panel menu, choose Open Brush 
Library > Bristle Brush > Bristle Brush Library 
(Figure 27).

5. Click any brush from the Bristle Brushes Library to add it 
to the Brushes panel.

6. Return to the Brushes panel.

7. You can specify different options for the different types 
of brushes. To change the options for a brush, double-
click the brush in the Brushes panel.

The Bristle Brush Options dialog box opens (Figure 31). 

8. Modify any of the brush characteristics or click OK to 
close the dialog box.

9. Set the Stroke color, weight, and other options in the 
Control panel. 

10. Draw freehand by dragging in the image (Figure 32).

11. Release the mouse button to complete the path 
(Figure 33).

When you are using the Paintbrush tool, the line’s edges 
have a much softer edge than they do with the Pencil tool.

Figure 30 Tools panel

Figure 31 Bristle Brush Options dialog box

Figure 32 Drawing with the Paintbrush tool

Figure 33 Completed Paintbrush tool path

Paintbrush tool
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Work with brush libraries

Brush libraries are collections of preset brushes that come with Illustrator. You can open multiple brush libraries to 
browse through their contents and select brushes (Figure 34). 

Figure 34 A selection of brush libraries

How to copy brushes from a brush library to the Brushes panel:

1. Open a brush library by using the Brushes panel menu 
(Figure 35).

You can also open brush libraries by choosing Window > 
Brush Libraries > [library].

2. Drag the brushes to the Brushes panel (Figure 36) or 
choose Add To Brushes from the brush library’s panel 
menu.

Figure 35 Detail of Brushes panel menu 

Figure 36 Drag to add to Brushes panel
How to draw in Illustrator © 2013 Adobe Systems Incorporated
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How to create new brush libraries:

1. Add the brushes you want to the Brushes panel, and 
delete any brushes you don’t want (Figure 37). 

2. Choose Save Brush Library from the Brushes panel menu 
(Figure 38).

3. Navigate to the location of where you want to save your 
brush library, name the file, and click Save.

The custom brush library is saved (Figure 39).

Figure 37 Customized Brushes panel

Figure 38 Detail of Brushes panel menu 

Figure 39 Saved custom brush library

How to import brushes into the Brushes panel from another file:

1. Choose Window > Brush Libraries > Other Library and 
select the file.

The custom Brush Library panel opens (Figure 40)

2. In the Brush Library panel, click on the individual brush 
definition or all the brush definitions that you need to 
import and select Add To Brushes from the Brush Library 
panel menu.

Figure 40 Custom Brush Library panel
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Painting with a brush made from a photo

Brush definitions can contain or hold images (non-vector artwork). You can define three types of image-based 
brushes: Scatter, Art, and Pattern. The behavior of the brushes is like any other brush: You can reshape or modify 
them. Images in a brush take the shape of the stroke; that is, the images can bend, scale, and stretch with the shape 
and type of stroke. Also, such brushes behave and can be modified in the same way as other brushes, using the Brush 
Options dialog box. For example, the leftmost image (below) is the original image. When using it in a brush 
definition, you could draw the three images on the right (Figure 41). Each stroke uses different scale options, 
specified in the Brush Options dialog box.

Figure 41 Art Brush Options dialog box and A. Original image, B. Image in a brush, scaled proportionately, C. 
Image in a brush, stretched to fit a curved stroke length, D. Image in a brush, stretched between guides

Note: Using large images in brushes impacts performance. Choose a small image to start with, or resize a large image 
down to a smaller scale for use as an image-based brush.

How to paint with a brush made from a photo:

1. In Illustrator, open an image file you want to convert into 
a brush by choosing File > Open.

The Place dialog box opens. 

2. Navigate to the location of the image, and click Open.

The image opens in Illustrator.

3. Choose the Selection tool from the Tools panel and scale 
the image down to a maximum width or height of 250 
pixels (Figure 42).

Holding down the Shift button allows the image to scale 
proportionally as you resize it.

4. Choose Window > Brushes to display the Brushes panel.

Figure 42 Scale an image down
How to draw in Illustrator © 2013 Adobe Systems Incorporated
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5. Select the object in the document and drag it over into the 
Brushes panel.

A small blue line appears in the panel showing you that 
the object is being added. When you release the mouse, 
the New Brush dialog box appears (Figure 43). 

Three brush options are available: Scatter Brush, Art 
Brush, and Pattern Brush. The other brush options are 
dimmed, as you cannot create an image-based brush in 
these formats.

You will work with the Art Brush option in this section. 
Be sure to experiment with the other brush options after 
you finish.

6. Select the Art Brush option and click OK.

The Art Brush Options dialog box opens (Figure 41).

7. Type a name for the brush in the Name text field.

8. Select Scale Proportionately in the Brush Scale Options 
area (Figure 44) and click OK.

The Art Brush Options dialog box closes.

9. Move the original object off the workspace onto the 
scratchboard. You will use it again to create another 
brush.

10. Click the newly created brush in the Brushes panel 
(Figure 45).

11. Choose the Paintbrush tool in the Tools panel.

12. Drag the Paintbrush tool in different locations to create a 
series of brush strokes (Figure 46). 

Observe that the image scales to the relative size of the 
stroke. Small strokes produce small images and larger 
strokes create bigger images while maintaining 
proportion.

13. Create another brush, but this time select Stretch To Fit 
Stroke Length and drag to create a curved path.

Observe how the image bends to accommodate the curve.

14. Create another brush, but this time select Stretch 
Between Guides.

15. Adjust the guide settings by changing the values in the 
Start and End boxes, or drag the guides in the preview 
area (Figure 47).

16. Click OK to close the Art Brush Options dialog box.

Observe how the image stretches between the guides.

Figure 43 New Brush dialog box

Figure 44 Art Brush Options dialog box detail

Figure 45 Brushes panel

Figure 46  Image in a brush, scaled proportionately 

Figure 47 Drag guides in preview area
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Drawing with the Blob Brush tool

You can use the Blob Brush tool to create freeform drawings, much like drawing with pixels in Adobe Photoshop or 
using natural media tools. The Blob Brush tool is particularly suitable for use with a pressure-sensitive tablet or stylus 
for creating editable vector art by using natural gestures. Unlike the Pencil and Paintbrush tools, the Blob Brush tool 
does not create paths; instead, your brush-like gestures create open areas with color. Drawing naturally with the Blob 
Brush tool delivers a unified area of color you can easily select and edit.

To draw with the Blob Brush tool:

1. Select the Blob Brush tool in the Tools panel (Figure 48).

2. In the Control panel, modify some options, including:

• Stroke color

• Stroke thickness

• Brush definition from the Brush picker menu

• Opacity

3. Paint freehand by dragging on the page (Figure 49).

4. Select the Eraser tool in the Tools panel.

5. Use the Eraser tool to edit the vector shape, such as 
splitting the vector shape into two pieces (Figure 50).

6. Choose the Selection tool in the Tools panel, select one 
piece of the split vector shape, and click on a corner 
anchor. Drag the corner to scale the shape. 

You can now edit the split vector shapes independently 
(Figure 51).

Figure 48 Tools panel

Figure 49 Drawing with the Blob Brush tool

Figure 50 Shape edited with the Eraser tool

Figure 51 Editing the split vector shape

Blob Brush tool

Eraser tool
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Drawing shapes

In addition to using brushes and the Pencil tool, you can draw shapes in Illustrator, such as rectangles, ellipses, and 
polygons. The colors of the interior and outline of the shape are determined by the fill and stroke colors, respectively.

In this section, you’ll learn how to draw a simple shape with stroke and fill, expand a shape, use Live Paint, and 
create new shapes by using the Shape Builder tool.

How to draw a shape:

1. Click one of the shape tools in the Tools panel, such as 
the Polygon tool (Figure 52).

Shape tools are located below the Type tool. By default, 
the Rectangle tool appears in the Tools panel. To access 
other shapes, click the Rectangle tool and hold down the 
mouse until the menu of shape tools opens.

2. Set the Fill, Stroke, and Stroke width for the shape in the 
Control panel (Figure 53).

3. Click the canvas where you want to put the shape.

• For the Rectangle, Rounded Rectangle, and Ellipse 
tools, click where you want the upper-left corner of 
the shape.

• For the Polygon, Star, and Flare tools, click where 
you want the center of the shape.

A shape options dialog box appears, such as the Polygon 
options dialog box (Figure 54).

Note: Alternately, you can drag on the canvas to make a 
polygon. You can press the Up Arrow and Down Arrow 
keys to add and remove sides from the polygon.

4. Enter options for the shape. For the polygon shape, enter 
a radius and number of sides.

5. Click OK.

The shape options dialog box closes and the shape 
appears in the document (Figure 55).

You can modify any of the shape’s attributes by selecting 
the shape with the Selection tool and modifying its 
properties in the Control panel.

Figure 52 Shape tools in the Tools panel

Figure 53 Control panel

Figure 54 Polygon options dialog box

Figure 55 Drawn polygon shape.
© 2013 Adobe Systems Incorporated How to draw in Illustrator 17

This document requires Adobe Illustrator CC, June 2013. Technical instructions may differ depending on your version.



Guide Adobe Illustrator

18
Expand objects

You can expand an object so you can then divide it into the multiple objects that make up its appearance. For 
example, if you expand a simple object, such as a circle with a solid-color fill and a stroke, the fill and the stroke each 
become discrete objects (Figure 56). If you expand more complex artwork, such as an object with a pattern fill, the 
pattern is divided into all of the distinct paths that created it.

Figure 56 Before (left) and after (right) expanding an object that has a fill and stroke

You typically expand an object when you want to modify the appearance attributes and other properties of specific 
elements within it. In addition, expanding objects may be helpful when you want to use an object that is native to 
Illustrator in a different application that doesn’t recognize the object.

How to expand objects:

1. Choose the Selection tool from the Tools panel and click 
on a shape in the workspace.

2. Choose Object > Expand.

The Expand dialog box opens (Figure 57).

Note: If the object has appearance attributes applied to it, 
the Object > Expand command is dimmed. In this case, 
choose Object > Expand Appearance and then choose 
Object > Expand. 

3. Set the Expand options:

• Object Expands complex objects, including live 
blends, envelopes, symbol sets, and flares.

• Fill Expands fills.

• Stroke Expands strokes.

• Gradient Mesh Expands gradients to a single mesh 
object.

• Specify Sets the tolerance for color values between 
color stops. Higher numbers help maintain a smooth 
color transition; low numbers can create a more 
banded appearance.

4. Click OK to close the Expand dialog box.

The object is expanded.

Figure 57 Expand dialog box
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Paint with Live Paint 

Illustrator provides two methods of painting. You can assign a fill, stroke, or both to an entire object. You can also 
convert the object to a Live Paint group and assigns fills or strokes to the separate edges and faces of paths within it 
(Figure 58). Converting your artwork to Live Paint groups allows you to color them freely, as you would a drawing 
on canvas or paper. You can stroke each path segment with a different color and fill each enclosed path (Note: not just 
closed paths) with a different color, pattern, or gradient.

Figure 58 An object consisting of a single path painted with the existing method has a single fill and a single stroke 
(left). The same object converted to a Live Paint group can be painted with a different fill for each face and a different 

stroke for each edge (right)

Live Paint is an intuitive way to create colored drawings. It lets you use the full range of Illustrator’s vector drawing 
tools but treats all the paths you draw as though they are on the same flat surface. That is, no path is behind or in front 
of any other. Instead, the paths divide the drawing surface up into areas, any of which can be colored, regardless of 
whether the area is bounded by a single path or by segments of multiple paths. The result is that painting objects is 
like filling in a coloring book or using watercolors to paint a pencil sketch.

Once you’ve made a Live Paint group, each path remains fully editable. When you move or adjust a path’s shape, the 
colors that had been previously applied don’t just stay where they were, like they do in natural media paintings or 
image editing programs. Instead, Illustrator automatically reapplies them to the new regions that are formed by the 
edited paths.

How to create a Live Paint group:

1. Choose the Selection tool from the Tools panel and select 
one or more paths, compound paths, or both in the 
workspace.

2. Choose Object > Live Paint > Make.

A Live Paint group bounding box appears around the 
selected object (Figure 59).

Note: Certain properties may be lost in the conversion to 
a Live Paint group, such as transparency and effects, 
while other objects cannot be converted (such as type, 
bitmap images, and brushes).

Figure 59 Live Paint bounding box around an 
object
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3. Choose Object > Expand. 

The Expand dialog box opens.

4. Set the Expand options and click OK to close the Expand 
dialog box.

The object is expanded (Figure 60).

5. Click and hold the Shape Builder tool to see and select 
the Live Paint Bucket tool (Figure 61). 

6. Specify the fill color or stroke color and size you want.

Note: If you select a color from the Swatches panel, the 
pointer changes to display three colors. The selected 
color is in the middle, and the two adjacent colors on the 
sides. To use an adjacent color, click the left or right 
arrow key.

7. To paint a face, click a face to fill it [when the pointer is 
over a face, it changes to a half-filled paint bucket and 
highlight lines surround the inside of the fill (Figure 62)] 
or drag across multiple faces to paint more than one face 
at a time.

Double-click a face to fill across unstroked edges into 
adjacent faces (flood fill). Triple-click a face to fill all 
faces that currently have the same fill.

8. To paint an edge, double-click the Live Paint Bucket tool 
and select Paint Strokes, or temporarily toggle to the 
Paint Strokes option by pressing Shift, and then click an 
edge to stroke it, or drag across multiple edges to stroke 
more than one edge at a time.

Double-click an edge to stroke all connected edges of the 
same color (flood stroke). Triple-click an edge to stroke 
all edges of the same stroke.

Figure 60 Expanded object

Figure 61 Tools panel

Figure 62 Click to apply color to a fill area 

Creating new shapes by using the Shape Builder tool

The Shape Builder tool is an interactive tool for creating complex shapes by merging and erasing simpler shapes. It 
works on simple and compound paths.

It intuitively highlights edges and regions for a selected artwork that can be merged to form new shapes. An edge is 
defined as the section of a path that does not intersect any other path of the selected objects. A region is a closed area 
bounded by edges.
How to draw in Illustrator © 2013 Adobe Systems Incorporated

This document requires Adobe Illustrator CC, June 2013. Technical instructions may differ depending on your version.



Adobe Illustrator Guide
To create a shape with the Shape Builder tool:

1. Create the shapes on which you want to apply the Shape 
Builder tool.

2. Using the Selection tool, select only the paths you need to 
merge to create the shape (Figure 63).

Note: Make sure that you select only those paths on 
which you need to apply the tool. 

3. Select the Shape Builder tool from the Tools panel 
(Figure 64). 

By default, the tool is in merge mode, ready to combine 
different paths. 

4. To merge two or more paths, drag across the regions 
enclosed by the paths. Each region is highlighted as you 
drag across it (Figure 65). Release the mouse button 
when all the regions are highlighted.

The regions are merged to form a new shape (Figure 66). 
Notice the topmost circle has not been merged into the 
shape. In the next step, you will delete a portion of that 
shape. 

The art style that the new shape inherits depends on the 
following rules:

• The art style of the object from where the mouse 
drag was initiated is applied to the merging shapes.

• If no art style is available on mouse down, the art 
style available on mouse release is applied to the 
merging shapes.

• If no art style is available on mouse down or mouse 
release, the art style of the topmost selected object in 
the Layers panel is applied.

For coloring, you can override these rules by selecting 
Color Swatches from the Pick Color From menu in the 
Shape Builder Tool Options dialog box. (Double-click 
the Shape Builder tool to open the Shape Builder Tool 
Options dialog box.)

Note: An alternative to dragging across the regions to be 
merged is to Shift-drag a rectangular marquee around the 
regions with the Shape Builder tool. When you release, 
the regions are merged.

Figure 63 Selecting paths

Figure 64 Tools panel

Figure 65 Selecting a region to merge

Figure 66 Merged shape

Shape Builder tool
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5. To use the Erase mode of the Shape Builder tool, Alt-
click (Windows) or Option-click (Mac OS) the closed 
region you want to delete.

In Erase mode, you can delete regions within selected 
shapes (Figure 67). If you delete a region that is shared 
by multiple objects, the shapes are broken in such a way 
that the regions selected by the marquee are removed 
from the shapes.

You can also delete edges in Erase mode. This option is 
useful when you want to clear the remaining portions 
after creating the required shape. Figure 67 Deleting a region within a selected 

shape
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