
Adobe Flash Professional Guide
How to draw and create shapes
You can add artwork to your Adobe Flash Professional documents in two ways: You can import images or draw 
original artwork in Flash by using the drawing tools in the Tools panel. 

Drawings you create in Flash are vector graphics. Vector graphics describe images by using lines and curves called 
vectors that also include color and position properties. When you edit a vector graphic, you modify the properties of 
the lines and curves that describe its shape. You can move, resize, reshape, and change the color of a vector graphic 
without changing the quality of its appearance. Vector graphics are resolution independent; that is, they can be 
displayed on output devices of varying resolutions without losing any quality. 

The files you import to Flash can be either vector graphics or bitmap images. Bitmap images (also known as raster 
images) are made up of pixels in a grid. Pixels are picture elements: tiny dots of individual color that make up what 
you see on your screen. A JPEG photograph is an example of a bitmap image. Because bitmaps are resolution 
dependent, it's difficult to increase or decrease their size without losing some image quality. Bitmap images are 
typically much larger in file size than vector graphics. 

The bitmap images you import to Flash can also be turned into vector drawings in two ways: You can break them 
apart to create a single vector shape or you can trace the bitmap to create a collection of vector shapes that resemble 
the original bitmap image.

In this guide you use the drawing tools to create and modify vector graphics. You also import bitmap images and 
convert them to vector shapes by using the Break Apart and Trace Bitmap commands.

Drawing with basic lines and shapes

One way to become familiar with the Flash drawing tools is to create something simple using basic lines and shapes.

Flash has two drawing modes: Merge Drawing and Object Drawing. Merge Drawing blends shapes when they 
overlap on the Stage. Shapes drawn on top of other shapes will merge, which means if you select one of the shapes 
and move it, the underneath shape is cut away (Figure 1).

Object drawing treats your shapes as grouped objects that can overlap without affecting each other (Figure 1). 

You can change between drawing modes by enabling or disabling Object Drawing in the Tools panel.

Figure 1 Merge Drawing (left) and Object Drawing (right)

Selecting drawing tools and setting properties

Flash drawing tools are available in the Tools panel. When you select a drawing tool, the properties for that tool 
appear in the Properties panel and any options for the selected tool appear at the bottom of the Tools panel. (You may 
need to enlarge the Flash window to see tool options.)

Most drawing tools have several properties in common, but each tool has a few unique properties.
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To set drawing tool properties:

1. Start Flash and open a new blank document 
(ActionScript 3.0).

2. Select the Oval tool in the Tools panel.

The Oval tool properties appear in the Properties panel 
(Figure 2). If the Properties panel isn’t open, select 
Window > Properties.

In the Properties panel, you can set the color, style, and 
size of the outer stroke of a shape. You can also change 
the color of the shape’s inner fill. 

You can select from several stroke types, such as solid or 
dashed lines.

Selecting the Hinting option enables stroke hinting. 
Stroke hinting adjusts line and curve anchors on full 
pixels to prevent blurry vertical or horizontal lines.

Cap settings control how the end of a path appears.

• None: The path ends flush—there is no cap.

• Round: Adds a round cap that extends beyond the 
path end by half the stroke width.

• Square: Adds a square cap that extends beyond the 
path end by half the stroke width.

Join settings define how two path segments meet 
(Figure 3). 

• Miter: Forms a sharp angle at the junction of two 
paths. To avoid beveling a mitered corner, enter a 
Miter value greater than 0.

• Round: Creates a smooth, rounded connection 
between two paths. 

• Bevel: Creates a beveled edge where two paths meet. 

The options in the Properties panel are slightly different 
for each drawing tool. For example, the Oval tool 
includes Start Angle, End Angle, and Inner Radius 
properties. 

The Rectangle tool includes Corner Radius properties for 
creating rounded corners (Figure 4).

If you are creating lines with the Brush tool or with the 
Pencil tool in Smooth mode, you can set the Smoothing 
value (Figure 5). Smoothing controls how Flash smooths 
out the curves in the lines you draw or paint. You can 
specify a value from 0 to 100. 

Figure 2 Properties panel, Oval tool

Figure 3 Join options (left to right): Miter, Round, 
Bevel

Figure 4 Rectangle tool corner radius options

Figure 5 Pencil and Brush tool Smoothing option

Stroke color Fill colorHinting option
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3. Make sure the Oval tool is still selected.

A tool’s modifier options are located in the options area 
at the bottom of the Tools panel (Figure 6). You may 
need to enlarge the Flash window to see tool options.

Options that are common to most Flash shape-drawing 
tools include:

• Stroke Color and Fill Color: Open a color palette 
to change stroke or fill color. In Merge Drawing 
mode, you must select a color before you begin 
drawing. You can also select stroke and fill colors 
in the Properties panel. 

• Black And White: Resets the stroke and fill colors 
to black stroke and white fill.

• Swap Colors: Swaps the current stroke and fill 
colors.

• Object Drawing: Toggles Object Drawing mode 
on and off. This is how you change between Merge 
Drawing and Object Drawing.

• Snap To Objects: Toggle the Snap To Objects 
feature on and off. This is off by default.

Figure 6 Tools panel, Oval tool modifier options

Creating a simple drawing with lines and shapes

A good way to become familiar with the Flash drawing tools is to create something very basic. In this activity, you 
use lines and shapes to create a simple drawing.

To draw in Merge Drawing mode:

1. Select the Oval tool in the Tools panel (if it’s not 
already selected). 

2. In the options section of the Tools panel, make sure 
Object Drawing is deselected.  

For now, you want to be in Merge Drawing mode.

3. Select a fill color for the shape, such as blue.

Note: You can select a fill color in the Properties panel 
or in the Tools panel.

4. Select a stroke color, such as black.

5. In the Properties panel, change the Stroke Height value 
to 15.

6. On the lower-center of the Stage, drag to draw an oval 
that is about 2 inches tall (Figure 7). 

Note: If you want to draw a perfect circle, hold down 
Shift as you drag the Oval tool on the Stage.

Figure 7 Oval shape with stroke and fill

Stroke color

Fill color

Black And White

Swap Colors

Object Drawing

Snap To Objects
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7. In the Properties panel, change the Oval tool fill color, 
perhaps to red.

8. Hold down Shift and drag on the Stage to create a perfect 
circle. Make it about the same size as the first oval and be 
sure the two shapes do not touch or overlap (Figure 8).

Note: If you make a mistake or don’t like what you’ve 
drawn, press Ctrl+Z (Windows) or Command+Z (Mac 
OS) to undo your drawing and start over.

9. Use the Selection tool to click the outline (stroke) of the 
top circle.

Only the outer stroke is selected.

10. Click the center (fill) of the top circle to select it.

Now only the fill is selected.

11. Double-click the fill of the top circle. 

The entire object (stroke and fill) is selected.

Note: If you double-click the stroke, only the stroke is 
selected. To select both the stroke and fill, you must 
double-click the fill.

12. With the top circle selected, drag it to the top portion of 
the bottom circle (Figure 9). 

13. Click away from the shapes to deselect them and then 
click once in the center of the top circle to select only its 
fill.

14. Press the Delete key.

Because you are drawing in merge mode, the selected fill 
disappears along with everything below it (Figure 10).

Next you draw in Object Drawing mode.

Figure 8 Two shapes with different fills

Figure 9 Drag to overlap the shapes

Figure 10 Merged shapes
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To draw in Object Drawing mode:

1. Select the Oval tool and then select the Object Drawing 
modifier in the options section at the bottom of the Tools 
panel (Figure 6).

2. Change the stroke color to light blue and the fill color to 
black. Change the Stroke Height value to 10.

3. Anywhere on the Stage, Shift-drag to draw a small circle 
in Object Drawing mode (Figure 11).

In Object Drawing mode, the shape’s stroke and fill are 
grouped as one object and share the same selection box. 

4. Use the Selection tool to select the circle you just drew, 
and in the Properties panel, change the Width (W) and 
Height (H) values to approximately 25 (Figure 12).

Note: You can click the Lock Width And Height Values 
Together option to constrain or unconstrain the height 
and width of the shape (Figure 12). 

5. With the small blue and black circle still selected, 
select Modify  > Convert to Symbol.

The Convert To Symbol dialog box appears (Figure 13).

6. Type blue_eye for Name, choose Graphic as the symbol 
Type, and click OK.

7. Open the Library panel, and drag another instance of the 
eye symbol to the Stage.

8. Use the Selection tool to drag both instances of the eye 
symbol into the empty space in the top circle shape 
(Figure 14).

You can place Object Drawings or symbols over other 
shapes without affecting the underlying shape.

One you place a symbol on the Stage, you can swap it for 
another symbol in the library. You do that next.

Figure 11 Small circle created in Object Drawing 
mode

Figure 12 Properties panel, Position And Size

Figure 13 Convert To Symbol dialog box

Figure 14 Shapes converted to symbols

Lock Width And Height Value 
Together option
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To swap symbol instances:

1. Create another small eye shape, only this time make the 
stroke color green. 

2. Convert the green eye shape to a new graphic symbol 
named green_eye.

Now you can create some characters with blue eyes and 
others with green eyes.

3. Use the Selection tool to select one of the blue_eye 
symbols on the Stage. 

4. In the Properties panel, click Swap (Figure 15).

The Swap Symbol dialog box appears (Figure 16).

5. Select the green_eye symbol in the Swap Symbol dialog 
box and click OK.

You have swapped the symbol on the Stage. Your 
character has one green eye and one blue eye 
(Figure 17).

6. Swap the other eye with a green eye so they match.

Next you use PolyStar tool to create a nose.

Figure 15 Properties panel, Swap button

Figure 16 Swap Symbol dialog box

Figure 17 Swapped symbols on the Stage
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To draw polygons and stars:

1. Select > Edit > Deselect All to make sure nothing is 
selected on the Stage.

2. Select the PolyStar tool in the Tools panel.

Note: The PolyStar tool shares the same space in the 
Tools panel as the Rectangle and Oval tools.

3. Open the Properties panel and change the fill color to 
black and the stroke color to None. 

Note: To set a stroke or fill color to None, click the color 
swatch in the Properties panel or in the Tools panel to 
open the color palette and click the None option 
(Figure 18). 

4. In the Tool Settings section of the Properties panel, click 
Options.

The Tool Settings dialog box appears (Figure 19). You 
can create polygons or stars.

5. In the Style menu, choose Polygon. Set the number of 
sides to 3 (to create a triangle), and click OK.

6. Drag to draw a triangle with one vertex pointing down 
(Figure 20).

7. In the Tools panel, select the Free Transform tool.

Free Transform selection handles appear around the 
selected shape (Figure 21).

8. Position the pointer over the lower-right selection handle 
of the triangle shape, and drag inward to reduce the size 
of the shape (Figure 21).

Note: You can hold down Shift as you drag to constrain 
the proportions of the shape. You can also resize the 
shape by entering Width (W) and Height (H) values in 
the Properties panel.

9. Use the Selection tool to select and drag the triangle 
below the eyes in your drawing (Figure 22).

Next you use the Line tool to create a mouth.

Figure 18 Stroke color palette

Figure 19  Tool Settings dialog box

Figure 20  Polygon shape

Figure 21  Free Transform selection

Figure 22  Position the triangle to create a nose

None
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To draw paths by using the Line, Pencil, and Brush tools:

1. Select the Line tool in the Tools panel.

2. In the Properties panel, select a stroke color and change 
the stroke height to 4.

3. Drag to draw a horizontal line below the triangle you just 
created (Figure 23).

4. Use the Selection tool to click an empty area of the Stage 
to deselect the line without selecting another shape.

5. Position the pointer along the bottom edge of the line and 
drag downward to modify the line (Figure 24).

6. Select the Brush tool in the Tools panel.

Notice the stroke options are disabled for the Brush tool 
in the Properties panel.

7. Select a fill color for the Brush tool in the Properties 
panel.

You can set painting options for the brush in the options 
section of the Tools panel (Figure 25).

• Object Drawing Mode: Toggle Object Drawing 
Mode on or off. 

• Lock Fill: When you select the Lock Fill modifier 
with the Brush or Paint Bucket tool and paint with 
the tool, the bitmap or gradient fill extends across the 
objects you paint on the Stage. 

• Brush Mode: Select from five painting modes.

• Paint Normal: Paints over lines and fills on the 
same layer.

• Paint Fills: Paints fills and empty areas, leaving 
lines unaffected.

• Paint Behind: Paints in blank areas of the Stage 
on the same layer, leaving other lines and fills 
unaffected.

• Paint Selection: Applies a new fill to the 
selection when you select a fill in the Fill Color 
control or the Fill box in the Properties panel, 
the same as selecting a filled area and applying a 
new fill.

• Paint Inside: Paints the fill in which you start a 
brush stroke and never paints lines. If you start 
painting in an empty area, the fill doesn’t affect 
any existing filled area.

• Brush Size and Brush Shape: Select a size and shape 
for the brush.

Figure 23  Position the triangle to create a mouth

Figure 24  Reshape the line to make a smile

Figure 25  Brush modifiers in the Tools panel

Lock Fill

Brush Size

Brush Mode

Brush Shape

Object Drawing Mode
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8. Experiment with the Brush tool by making several brush 
strokes on the Stage. 

In this example, we used the Brush to make antennae for 
the bug-like character who has been taking shape 
throughout this activity (Figure 26).

9. Select the Pencil tool in the Tools panel.

Notice the fill color option is disabled for the Pencil tool 
in the Properties panel.

10. Select a stroke color and set a stroke height for the Pencil.

Flash offers three pencil drawing modes, available in the 
options section of the Tools panel.

• Straighten: Draws straight line segments.

• Smooth: Draws curvy lines with smooth curves.

• Ink: Draws freehand lines with no modification 
applied.

11. Use the Pencil tool to put some final touches on your 
drawing (Figure 27). 

Note: Because you are still in Object Drawing mode, 
overlapping your existing shapes will not affect them.

Now you’ve created your entire character and have 
several shapes arranged on the stage.

Figure 26  Brush strokes used to create antennae

Figure 27  Smooth pencil lines used to create arms 
and legs
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Creating decorative fills by using the Deco tool

Designing the settings in a Flash movie or the virtual world in a game can be similar to designing sets or locations in 
a live-action movie. You don’t need to be a fine artist to include stylish backgrounds in Flash. By using the Deco 
(decorative) tool with its various drawing effects, you can turn symbols into complex geometric patterns with creative 
artistic fills.

Some Deco tool drawing effects, such as the Tree Brush or Lightning Brush, do not use symbols. Other Deco tool 
drawing effects, such as Grid Fills, require that you select a symbol in the document library to use as the artwork for 
the decorative fill.

The Symmetry effect

Use the Deco tool Symmetry effect to arrange symbols symmetrically around a central point.

To apply the Symmetry effect:

1. Open a Flash document that contains symbols or open a 
new blank Flash document (ActionScript 3.0) and use the 
shape tools to create a few new graphic symbols. 

Note: Smaller symbols work best when you are creating 
decorative fills. 

2. Select the Deco tool in the Tools panel.

Properties for the Deco tool appear in the Properties 
panel (Figure 28).

3. Select Symmetry Brush from the Drawing Effect menu in 
the Properties panel (Figure 29).

4. In the Properties panel, click the Edit button.

The Select Symbol dialog box appears. It shows the 
symbols in the library (Figure 30).

You can use any movie clip or graphic symbol in the 
library with the Symmetry Brush effect. This symbol-
based effect gives you a great deal of creative control 
over artwork you create in Flash.

5. Select one of the symbols you created and click OK.

Figure 28 Properties panel, Deco tool

Figure 29 Drawing Effect menu

Figure 30 Select Symbol dialog box

Deco tool
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6. In the Properties panel, choose one of the options from 
the Advanced Options menu (Figure 31). 

• Reflect Across Line: Flips the shapes an equal 
distance apart across an invisible line that you 
specify.

• Reflect Across Point: Places two shapes an equal 
distance apart around a fixed point that you specify.

• Rotate Around: Rotates the shapes in the symmetry 
around a fixed point that you designate. The default 
reference point is the center point of the symmetry. 
To rotate the object around its center point, drag in a 
circular motion.

• Grid Translation: Creates a grid by using the shapes 
in the Symmetry effect you are drawing. Each click 
of the Deco tool on the Stage creates a grid of 
shapes. Adjust the height and width of the shapes by 
using the x and y coordinates defined by the 
Symmetry Brush handles.

7. Click the Stage where you want the Symmetry Brush 
artwork to appear (Figure 32).

8. Use the Symmetry Brush handles to adjust the size of the 
symmetry and the number of symbol instances. 

9. Select Edit > Select All and press Delete. 

You will start the next activity with an empty Stage.

Figure 31 Advanced Options menu

Figure 32 Placing symbols with the Symmetry 
Brush
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The Grid Fill effect

You can use the Grid Fill effect to fill the Stage, a symbol, or a closed region with a symbol from the library. After 
you draw a Grid Fill on the Stage, if you move or resize the filled symbol, the Grid Fill moves or resizes accordingly.

The Grid Fill effect creates a repeating tiled background or an area or shape with a custom pattern. The default 
symbol for the Grid Fill effect is a 25-by-25-pixel black rectangular shape with no stroke.

To apply the Grid Fill effect:

1. Select the Deco tool, and select Grid Fill from the 
Drawing Effect menu in the Properties panel (Figure 33).

You can use any movie clip or graphic symbol in the 
library with the Grid Fill effect. You can use the same 
symbol for all tiles or combine up to four symbols. The 
default shape is a small black square. You an change the 
color used for the default shape by clicking the color 
swatch for each tile and picking a new color.

2. In the Properties panel, click the Tile 1 Edit button to 
select a symbol from the library.

The Select Symbol dialog box appears, listing symbols in 
the document library.

3. Select a symbol in the Select Symbol dialog box and 
click OK.

You can use the following advanced options in the 
Properties panel to specify the horizontal and vertical 
spacing and the scale of the fill shape.

• Horizontal Spacing: Specifies the horizontal 
distance in pixels between shapes used in the Grid 
Fill.

• Vertical Spacing: Specifies the vertical distance in 
pixels between shapes used in the Grid Fill.

• Pattern Scale: Enlarges or shrinks an object 
horizontally (along the x axis) and vertically (along 
the y axis).

After you apply the Grid Fill effect, you cannot change 
the advanced options to alter the fill pattern.

4. Click the Stage or click within a shape or symbol where 
you want the Grid Fill pattern to appear.

The pattern fills the area (Figure 34). If you want the 
entire grid filled with the same symbol, select that 
symbol for all four tiles in the Properties panel.

5. Select Edit > Select All and press Delete. 

You will start the next activity with an empty Stage.

Figure 33 Deco tool Grid Fill properties

Figure 34 Grid Fill pattern
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The 3D Brush effect

You can use the 3D Brush effect to spray symbols so they appear to be in front of each other. After you draw a 3D 
Brush on the Stage, if you resize or otherwise change the filled symbol, the 3D Brush changes accordingly.

To apply the 3D Brush effect:

1. Select the Deco tool, and select 3D Brush from the 
Drawing Effect menu in the Properties panel (Figure 35).

Similar to the Grid Fill effect, you can choose the 
symbols or default shapes to use when drawing.

2. In the Properties panel, click the Object 1 Edit button to 
select a symbol from the library.

The Select Symbol dialog box appears.

You can use any movie clip or graphic symbol in the 
library with the 3D Brush effect.

3. Select a symbol in the Select Symbol dialog box and 
click OK.

You can use the following advanced options in the 
Properties panel.

• Max Objects: Specifies the total number of shapes 
used in the 3D Brush.

• Spray Area: Specifies the area covered in each spray 
of the 3D Brush.

• Perspective: Specifies that objects appear in front of 
each other.

• Distance Scale: Specifies how far in front of each 
other objects appear to be.

• Random Scale Range: Specifies the degree to which 
objects vary in size.

• Random Rotation Range: Specifies the degree to 
which objects are rotated.

Note: After you apply the 3D Brush effect, you cannot 
change the advanced options to alter the fill pattern.

4. Drag the pointer across the Stage to draw with the 3D 
Brush (Figure 36).

As you drag, Flash paints a pattern using the objects you 
selected in the Properties panel. 

5. Select Edit > Select All and press Delete. 

You will start the next activity with an empty Stage.

Figure 35 Deco tool 3D Brush properties 

Figure 36 Placing symbols with the 3D Brush 
effect
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The Vine Fill effect

You can use the Vine Fill effect to fill the Stage, a symbol, or a closed region with a vine-like pattern. You can 
substitute your own artwork for the leaves and flowers by selecting symbols from the library. The resulting pattern is 
contained in a movie clip that itself contains the symbols that make up the pattern.

To apply the Vine Fill effect:

1. Select the Deco tool, and select Vine Fill from the 
Drawing Effect menu in the Properties panel (Figure 37).

By default, the Vine Fill effect uses a leaf and flower as 
the artwork for the fill. You can change these to custom 
symbols by clicking the Edit buttons and selecting 
symbols in the document library.

You can set the following Advanced Options in the 
Properties panel:

• Branch Angle: Specifies the angle of the branch 
pattern.

• Branch Color: The color box to the right of Branch 
Angle. Specifies the color for the branch.

• Pattern Scale: Adjusts an object by enlarging or 
reducing it both horizontally (along the x axis), and 
vertically (along the y axis).

• Segment Length: Specifies the length of the 
segments between leaf and flower nodes.

• Animate Pattern: Specifies that each iteration of the 
effect is drawn to a new frame in the Timeline. This 
option creates a frame-by-frame animated sequence 
of the flower pattern as it is drawn.

• Frame Step: Specifies how many frames to span per 
second of the effect being drawn.

Note: After you apply the Vine Fill effect, you cannot 
change the advanced options in the Properties panel to 
alter the fill pattern.

2. Click the Stage or click within the shape or symbol where 
you want the Vine Fill pattern to appear.

The pattern fills the area (Figure 38).

3. Select Edit > Select All and press Delete. 

You will start the next activity with an empty Stage.

Figure 37 Deco tool Vine Fill properties

Figure 38 Vine Fill pattern
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Converting text and bitmap images to vector shapes

In addition to drawing vector shapes in Flash, you can import bitmap graphics, such as photographs, and convert 
them to vector artwork. Converting large bitmaps to vectors can significantly reduce the file size of your document.

Flash provides two ways to convert a bitmap image to a vector shape: Break Apart converts the entire bitmap into a 
single shape. Trace Bitmap analyzes the colors in the bitmap image and creates a collection of merged shapes.

Using the Break Apart command

The Break Apart command appears in the Modify menu.

You can break apart bitmaps and text to create vector shapes. When you break apart text, you can use the resulting 
shape in an animation that morphs the shape into another shape. 

When objects or symbols are grouped, using Break Apart ungroups them into separate objects. You may need to use 
Break Apart several times to completely ungroup objects before you can convert them into vector drawings. 

To break apart text:

1. Use the Text tool to create some text. Use the Selection 
tool to select the text.

2. Select Modify > Break Apart.

The text is ungrouped into separate letters (Figure 39). 
You can now select and modify each letter as a separate 
object, but they are still not vector shapes, as shown in 
the Properties panel (Figure 41). You need to break them 
apart a second time to convert them to vector shapes.

3. Select Modify > Break Apart again.

Flash converts the selected letters into several shapes 
(Figure 40), as shown at the top of the Properties panel 
(Figure 41). 

4. Select Edit > Select All and press Delete. 

You will start the next activity with an empty Stage.

Figure 39 Text broken into separate objects

Figure 40 Letter objects broken into shapes

Figure 41 Properties panel, shape properties
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To break apart a bitmap image:

1. Select the bitmap you want to break apart.

Note: To import a bitmap image, you can choose File > 
Import > Import To Stage, select the file to import, and 
click Open. 

2. Select Modify > Break Apart.

Flash converts the bitmap image to a shape, as shown at 
the top of the Properties panel (Figure 42).

The selected image is filled with a consistent pattern to 
show it’s selected as a single shape object (Figure 43).

3. Click away from the shape or select Edit > Deselect All 
to deselect the shape.

4. Click the shape again to select it.

The entire shape is selected as a single object.

5. Select Modify > Combine Objects > Union.

The shape is grouped as a single drawing object, as 
shown in the Properties panel (Figure 44). You can now 
apply stroke and fill properties.

6. Select Edit > Select All and press Delete.

Figure 42 Properties panel, shape properties

Figure 43 Selected shape

Figure 44 Properties panel, drawing object
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Using Trace Bitmap

In this activity, you trace the same bitmap you broke apart in the previous activity to see the difference between Break 
Apart and Trace Bitmap.

To trace a bitmap image:

1. Select the bitmap you want to break apart.

Note: If you’ve already imported the image, you can drag 
a fresh copy of the image from the Library panel to the 
Stage. 

2. Select Modify > Bitmap > Trace Bitmap.

The Trace Bitmap dialog box appears (Figure 45). 
Tracing will occur based on colors and lines in the image. 
You can adjust how sensitive Flash is when analyzing the 
bitmap. 

3. Click OK to accept the default Trace Bitmap settings.

Flash traces the bitmap and creates an artistic rendering 
of the image. The resulting object is a vector shape, as 
shown in the Properties panel.

4. Click away from the image or select Edit > Deselect All 
to deselect the shape.

5. Click in the image again.

Only a portion of the image is selected (Figure 46). 
When you trace a bitmap, the resulting vector drawing is 
a collection of merged shapes.

Figure 45 Trace Bitmap dialog box

Figure 46 Traced bitmap converted to shapes
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Using adaptive scaling to produce a Flash document for multiple screens

It used to be that one of the most time-consuming tasks of designing content in Flash was to size and optimize your 
movie for multiple screen sizes. With Adobe Flash Professional, you can now choose to scale the contents of your 
document when you change the Stage size. All objects on the Stage, including symbols, shapes, paths, motion paths, 
and bitmap images across all scenes, are scaled together.

To scale a document by using adaptive scaling:

1. Select Modify > Document.

The Document Settings dialog box appears (Figure 47). 

When you change the Dimensions settings of the 
document, the Scale Content With Stage option becomes 
active. This option activates adaptive scaling.

2. To change the document dimensions, select Scale 
Content With Stage, and click OK.

The content resizes along with the Stage.

3. Select Edit > Undo Modify FLA Document to return the 
Stage and content to their original dimensions.

Figure 47 Document Settings dialog box
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